I can no longer use SmartThings with Alexa

All of a sudden it seems like everything is going wrong. First, my Honeywell TCC thermostat went off and won’t come back on. I’ve checked the breaker and don’t know what to do short of un-wiring it and wiring up the old one to check if the thermostat itself died. After that, Alexa stopped working with my devices, saying “this command does not work with [insert device name here].” Everything (except the disconnected thermostat) still works in the SmartThings app though.

So I started troubleshooting. First, I removed a device from Alexa, re-added it in the SmartThings SmartApp, and then I ran device discovery on Alexa, which found it. Tried voice command again and same result. After that, I removed the SmartThings skill in Alexa and the SmartApp from SmartThings. Then I tried enabling the skill again, except this time, when I tap “Enable”, I get a blank screen and nothing happens. On the SmartThings side, well, the SmartApp is gone until I can re-link it from Alexa.

Also, I should probably add, I’ve tried enabling the skill from a tablet, smart phone, and the Bluestacks app on PC, all with the same result.

So… Any suggestions? Is this an issue on SmartThings side, something due to updates, or am I doing something wrong?


I just noticed that. So I guess that explains most of the issues. The thermostat is probably unrelated. I’ll post an update if the problems persist.

Alexa is now working again for me. Looks like the issues have been fixed.