Ecobee - Amazon Echo Issue

Before I start tearing things apart… anyone else experiencing issues with Alexa controlling either the Ecobee 3 or 4 via SmartThings? She makes the temperature change as requested, can see it in the live log and thermostat, but always responds with “Hrm… I’m having trouble reaching SmartThings”. Happens on two different units.

Everything else seems to be working with the exception of a lot of slowness since the last hub upgrade.

The issue is this: Alexa sees the ecobee both on its own, AND as a device in SmartThings.

My solution to the problem is this: in Alexa, rename the devices. The one(s) you want to use via Alexa are the ones where Alexa and ecobee are interacting directly. Rename those devices to what you want to call them when issuing voice commands. Mine is called ‘thermostat’ :smile: Then in Alexa, call the SmartThings ecobee device something else. Call it ‘fred’ or whatever word you won’t be using at all in Alexa.

So when you say “Alexa, turn down the thermostat” it has only one viable option: the direct link to the ecobee.

If its a duplicate device issue due to both the ecobee skill and smartthings skill being installed, then manully select device in the smartthings app you want alexa to see and don’t include the ecobee ones.

1 Like

Never, include any device with direct GH/Alexa skill in your list of ST devices authorized to Alexa/GH.

Not sure this is the case, although I’m happy to be wrong… you guys are even more than welcome to throw something at me if I am.

First the obvious statement everyone always makes - it worked for the last several months. I don’t have the Ecobee skill installed and when I go to the Alexa web console and delete the thermostats (they do show under SmartThings control and I can manipulate them from the Alexa app - i.e., change temperature, etc.) she gives me the expected “I don’t have an Apartment Thermostat”.

Running discovery yields no devices until I re-enable them in the ST Alexa application then discovery picks them up. When I attempt to control them I get the response about ST not responding.

Does Alexa see the Ecobee thermostats w/o the skill through a native integration? I didn’t think so but could be wrong.

EDIT: Also noticed that even though she tells me she is having trouble reaching ST the action still takes place. Both thermostats change temperature.

Thanks for the responses guys!


I think it may be just an Alexa bug. I get the same with a few of my devices ( though I haven’t noticed it since 19.19 FW ). Alexa would say xxx is not responding, but the device still turns on/off as instructed. I just attributed it to her having another mental breakdown.

Tend to agree… ripped everything out and put it back. It actually works now to some degree. Current temperature reports when asked and changes happen. Oddly if I tell her to change the temperature to 70 she does it but announces that the 'current temperature is 72 (or current set point). Repeating the command announces the correct set point.