SmartThings Community

Hue integration stopped working (27 June 2019)

Mine are working however some (not all) of my Hue bulbs are going offline and online repeatedly in the ST app. Again, this is post the ST hub FW update yesterday.

UPDATE: Appears to be Device Health related. But definitely started right after ST hub FW update yesterday.

I don’t think I have seen this before in Live Logging for my Hue bridge:

9:55:21 AM: error java.lang.NumberFormatException: For input string: "2." @line 701 (getHost)

For reference I have opened a ticket with Support - ticket #759326.

4 Likes

Add me to the list of people that are now seeing Hue Offline since this update.

Support ticket opened - #759122

1 Like

Of course Support recommend I power cycle the ST hub and bulbs.

I did it just for kicks but seriously. There were updates to the Hue integration this release and the logging error I reported seemed to have been ignored.

1 Like

Same here. It happened yesterday Jun 27.
Something has changed on ST hub. I rebooted the ST hub but to no avail.

Power cycling everything has not stopped my offline/online cycling on the bulbs.

Waiting to see if error in Live Logging for Hue bridge has gone away or not. It was previously consistent every ten minutes.

But this is interesting - stumbled on by chance. In Live Logging for Smart Locks I have this:

Why would there be reference to Hue Dimmable in Smart Locks?

Is anyone seeing Hue issues and not using the HA emulated hue bridge?

1 Like

Not sure I fully understand. I have a Hue bridge, the physical device. I do not use a Hue emulator of any kind.

My Hue issues are that I see frequent device health-based offline/online messages in the “Recently” tab for some of my Hue bulbs. My Hue devices are still controllable. I was getting some Live Logging errors for Hue bridge but for now they seem to have stopped.

I’m trying to suss out the scope of the issue. We have users who are using the HA emulated hue bridge who are reporting an issue so I’d like to establish if others who are not using the emulated hue bridge are also seeing issues, as it is likely a different root cause.

Based on your response, it sounds like the reports in this thread are unrelated to the emulated hue bridge issue - aside from chopperj.

3 Likes

I’m using the official Phillips Hue Bridge.

1 Like

I looked at the device you reported in your support ticket. It does seem to have been very solid up until the hub firmware update when it started flip flopping online/offline. I don’t have a good explanation unfortunately but will flag it.

2 Likes

How are you re-adding the hue bridge? I looked at the logs and didn’t see the expected rejoin attempt.

Thanks Brad.

1 Like

I am adding a new device for Phillips Hue and following the instructions to unplug the Ethernet cable, wait 10 seconds, plug and then hit the Hue Bridge button, but nothing happens in the app after doing so.

Can you try using the + option from the Classic app? I’m not seeing join events.

I don’t see anything in The official instructions about unplugging the ethernet, and there are a number of reasons why that might cause a timing issue when you went to join. Is that an instruction from Hue or from SmartThings?

Thanks Brad,

I tried both the classic and new app and both can’t find the hue bridge, it just times out after a while, before the firmware and android app update there were no issues and smartthings could see the bridge fine.

It is an instruction from the android smartthings app

Also tried connecting from an iPhone and still the ST app won’t find the hue bridge, even though the bridge works fine by itself.

I have this same problem. The Hue integration stopped working after the firmware upgrade. No problem controlling both the Philips Hue lamps and the Ikea lamps by use of the Philips Hue hub, but impossible to control them by use of the ST hub. Before the upgrade everything worked perfectly.

I’m seeing same problem with HA-Bridge