Hue bulbs not controllable because of bad bridge ID


#1

OK, some people are reporting that somehow the network ID for the Hue bridge got corrupted and that after that SmartThings could no longer control Hue bulbs although other systems with independent connections to the Hue bridge still worked fine.

@cmeans has a manual fix for that specific problem discussed in the following post.

Note that this is different than the earlier one that was in beta where high volumes of polling caused by a previous platform update were causing those who had more than about 15 devices connected to the bridge to get a problem where the smartthings hub kept rebooting. This new one doesn’t involve any rebooting, the bulbs just can’t be controlled.


New Hue delay
(Mike Maxwell) #2

Hmm… my hubs been randomly going on and off line for a few weeks, and is still doing it. I see a crap ton of SSDP every minute spewing out of the samsung audio connect app… related?


#3

Sounds likely, but not due to the bad bridge ID, but rather one of the other two current known hue problems. . It turns out that that actual problem isn’t the hue bridge itself. It’s just the volume of messages that have been introduced by changing the polling of the hue bridge from once every five minutes to once every five seconds. There were some reports that people were having the same problem with Sonos even if they didn’t have a hue bridge. It’s just the ST hub getting flooded and losing track of where it is and in some cases even rebooting.

It does raise the question of whether the new polling was ever tested with a hue bridge that had the max 50 devices on it.


(Chris Means) #4

Support was no help for me, but what I found on my own is that though the IP address was correct for my Hue, there’s an additional ID value, and they were different.

So, I took the ID value reported by the Hue app for my bridge, and I used the SmartThings Web UI to edit the Philips Hue Hub device entry and replaced the bad ID with the correct one (there were some extra numbers prefixed, which I left as they were). Once I did that and re-stepped through the Hue (Connect) setup, everything matched up and I didn’t have to reset anything else and all my bulb configurations stayed in place.

So happy to be able to tell Alexa to turn my lights on/off again.


(Realy Living Dream) #5

Simple solution to that is to just add Hue DIRECTLY to Alexa. Just make sure you don’t authorize any hues connected directly a second time in ST, or each light will show twice in Alexa .


(Jason "The Enabler" as deemed so by @Smart) #6

@slagle

You wanna verify and pass this on to the engineers? ? ? ? Might just lead you guys out of the dark.


(Jason "The Enabler" as deemed so by @Smart) #7

I have my hue connected directly to Alexa, and it is integrated in ST via echo connect…

I’m not seeing any problems at all… But now I’ll get home and have nothing but darkness!


(Wayne) #8

Nope pretty random. Pretty fed up to be honest. Going to leave the whole thing broken and go to bed. System seems worse in the evening. (Probably because I need the lights more!!)


(Realy Living Dream) #9

I never had any problems controlling Hues with Alexa. Issue was controlling with ST. Turn lights on with Harmony or Alexa. Then attempt to change color or turn off with ST and ST would get all confused since it had not turned them on ( I assume). Open ST app, select the room with the lights and Hues would be stuck on " turning on" or " turning off" . Open up logs for the light and see ST had sent on or off command to light every second for the past ___ minutes ( trying to figure out if it was on or off ? )


(Brian) #10

Ok looked at that ID thought it might help but I can’t find anywhere in the IDE to change the HUE IDnumber I can see it but can’t edit it. Assuming you didn’t mean device network ID.which I tried changing but had no effect.


(Jason "The Enabler" as deemed so by @Smart) #11

Any chance you might be looking at a harmony issue here? Have you tried removing the bulbs from harmony control?


(Jason "The Enabler" as deemed so by @Smart) #12

Did you look at the individual devices under the my devices tab?


(Brian) #13

Yes checked the hub but can’t change the device ID.


(Jason "The Enabler" as deemed so by @Smart) #14

What about the bulbs? Did you tap on edit?


(Realy Living Dream) #15

If it was Harmony wouldn’t work. I tap the button on Harmony to turn on lights, they turn on, I press the rocker they dim, I hold the button they turn off.
If I tell Alexa " Turn on lvingroom blooms" they turn on. I tell Alexa to turn off the blooms, they turn off. I open ST, go to living room and the blooms are not on or off. The button says " turning on" or " Turning off" . I can open it first thing in the morning, and they will still be " turning off" from when I ran good night the night before. Or it did before support removed all my Hues
It is the same ( or close to the same) issue ST " fixed" with the patch a few weeks ago with ST not getting updated states from Hue.


(Jason "The Enabler" as deemed so by @Smart) #16

Make sure you go through “my devices”. Choose the hue bridge. Tap on edit and scroll down.

Write down the number that’s there before you change it!


(Brian) #17

Tried that

Ended up with the standard list

The only relevant ID change I can make is to the Device Network ID which was populated by a whole stack of 0’s

I’ve changed that to the Hue ID but am not seeing any affect

The other ID field (idNumber) cannot be edited and that to is a bunch of 0’s

I think we are on the right track though.

Interestingly any attempt to run connect resets the ID.

Might try another bridge which I have hiding upstairs somewhere if I don’t get anywhere with support.


(Jason "The Enabler" as deemed so by @Smart) #18

Does your device network id in the ST web use match what the hue app is showing as your hub Mac address?

If not, it should.


(Brian) #19

No it doesn’t its a bunch of 0’s, I’ll try the MAC address


(Jason "The Enabler" as deemed so by @Smart) #20

I bet that will fix it… Leave the colons out