Hub wouldn't connect until I disabled 5ghz wifi? Or coincidence?

last week I had to do a factory reset on my router, since then the hub will not connect. I’ve done the restart, tried every Ethernet cable in my house, tried every port on my router, tried additional routers in between, hooked up directly to the modem, opened up the 6 ports suggest, and then put the router in a DMZ, made sure the reset button wasn’t getting pressed in from the case not aligning. I’ve even hooked up the power adapter to my multimeter to check the adapter (it’s fine).

Just now I tried adding the hubs mac address (which I got from the ide page) to apply a static route to it. After restarting the router it connected and gave a solid blue light for over 30 min. then went INACTIVE in the IDE. The whole time it showed inactive on the phone app. I decided to cycle the hub and now I 'm back to blue blinking lights and it won’t connect to the router again.

So as I write this, literally at this point in my typing, I tried one more thing out of desperation. I’ve turned off any 5gz signals on my wireless (not sure why, just reaching at this point). and the hub just came on green and appears to be ‘on line’ in every way. Was this a coincidence or did disabling my 5ghz wireless actually do something?

I’m more concerned for if this happens again. I want to play with it to test some theories, but I don’t want to go dark again. I’ve become to accustomed to my smart home to go back :slight_smile:

EDIT: as I post this it just disconnected again, lights on the front are solid blue. Nothing makes sense anymore.

EDIT 2: The hub is up and running over 24hrs now. I’m guessing I had a fringe case scenario, but as I’ve read it’s a good idea to assign an IP to the Hub anyway.

Captains Log: unplugged the cable from the router, plugged it back in to the same port. turned green instantly. I checked the calendar, it’s not Friday the 13th, so I feel like I’m being trolled. How long will my connection status last? Hard to tell. Please pray for me.


Wow, that sounds frustrating. :disappointed_relieved: I hope you find a fix soon.

What did support say? Did they have any ideas?

I know there are a couple of outstanding issues where the hub keeps disconnecting, but I don’t remember all the details.

I know there’s a current closed beta which is supposed to address at least one of the reasons for this problem.

Thanks, I didn’t actually call support yet, that was my next stop. I know it’s the wrong attitude, but by the time I get done going through all the motions with support I’m left with ‘send it back and we’ll take a look at it.’ Being a fairly technical person I wanted to figure this one out, and not cop out to “a bug”.

The hub came back on line, and has been solid now for 30 min. I’m going to put logging on it to check it’s transactions. The only thing I can think of is the hub holds ip and routing pretty hard and doesn’t try to re-adjust when network conditions change. When I added a static DHCP to it it might have connected, and then spent the time downloading new firmware, possibly longer then the ST noted time of “up to 30 min”.

I’m going to keep a steady eye on it, I’d really like to know what I did wrong in the first place to avoid this. Possibly help out someone else.


Which router do you have? I had a router (and I can’t remember who manufactured it but it wasn’t cheap) that would cause similar problems with my Harmony hub. I’d reboot my router and it would be fine for a bit. Replaced the router and everything was fine.

I have a Linksys EA9500, yeah, not cheap. I found out a while back that one of my twisted strands from my modem to the router was busted. I attributed all my network issues to that, and had relatively no issues since, but am still waiting to see.

I think it’s very bizarre that the ST hub wouldn’t connect to it’s IP until I reserved it. The ip listed in the IDE was open and available on my router. Not sure which one to blame for this, but 20 hours and still going strong so far.

I Think I may have had the same one. The darn thing eventually kept rebooting on me at random times. I ended up going with an airport extreme and everything has been fine.

What happens if you do not reserve it?

If I dont reserve the IP the hub flahes blue as in it cant get a valid IP. On the router I don’t see the hub try to connect, or any indication that it ever was connected.

Man, that is not what i want to hear. I was having problems about every three months were wired devices wouldnt be connected by wifi devices would be fine.

I found some wires in the ethernet from the modem where broke, and was hoping all the weirdness was attributes to that. It has only been a month so i cant say for sure yet.

Next troubleshooting step would be to only connect the hub with a cable you know it’s good.
Also, go into the router, LAN/DHCP reservations and see if thre’s anything there. If there is, delete them and restart router.
Let me know the result.
BTW, there’s no relation between 5gHz and wired connection. It seem that somehow there is a conflicting IP address.

You can only see that in the system log

The broken strands in the cat5 where leading up to my issues with the router. Once I remade the ends That cleared up all problems with the router and all other devices on the network. While I’m sure it contributed I didn’t root cause that to issues with the SmartThings hub.

I believe the 5ghz bands was just a coincidence, there shouldn’t be any relation between my wifi bands and the wired ports, except… there is when the router has issues. Makes no sense but I’ve had times in the past where wifi works fine while all wired connections are disconnected. It could also contribute to a compounding issue/bug within the router’s OS. There where no other DHCP reservations in the router, and there was no device assigned the IP last registered to the hub as listed in the IDE.

The hub has been working over 24 hours straight now. I’m guessing after I manually assigned the IP it was working, but for whatever reason was taking longer than 30 min for updates to take effect.


Glad to hear it works.
I understand you’re doing your own cables. Use EZ-RJ45 connectors and you won’t have these problems any more.