Hub v2 network connection dropping

Over the last few weeks my v2 hub has started dropping the LAN connection all the time - like every few minutes (little blue LED comes on and no connectivity etc) . I thought it was cable/lan switch etc and have changed both but still the same and all over LAN devices operate fine.

Anyone else experienced this ? any ideas ? - I have tried powering off for 20+ minutes etc but no change.

If I reset the hub do I lose all my configuration etc ?

Just in writing this post I have seen it drop the connection twice ! then come back.

You may want to contact ST support on this issue and let them investigate.

Resetting the hub may not resolve the issue so I would hold off on that.

Have you rebooted your router

Hi yes good idea re support, yes the router has been rebooted - BUT a few weeks ago I changed the router from giving out a fixed IP to the hub to doing it dynamically, about 20 mins ago I changed it back to a fixed IP and since then it seems to be stable , so may have been DHCP related, was only 20 mins ago so monitoring it.

THanks for the feedback


Hi, yes I’ve had this today in last 3 hours, my v2 hub has disconnected twice from lan for no reason.

Update: in fact it’s now happened a 3rd time at 8:40pm gmt.
and I when I. Look it has happened at 40 mins each hour each time.
Not sure of any relevance