Hub Offline in app but everything still works

Since being forced to use the new app (never had this problem on the old one), the Android app always shows the Hub as being offline. However, everything works just fine. No matter what I do to try to get the hub to show online, nothing changes.


If the hub isn’t already in a Room, put it in one.

That is definitely a cure for something, I just can’t remember what.

It has been in a room. Further investigation shows even odder behavior. The header at the top of the app says it is offline, and clicking on it shows the offline details. However, scrolling down to the room it is assigned to shows the same hub online. This app is crap.

I have literally the same issue as you except I’m iOS. I’ve rebooted it a few times to no avail. My home assistant integration is still working fine with it so likely an issue between the app and their apis. Very frustrating.

I get nothing but a spinning wheel for hours now. Alexa integration is also not working.

I am able to see my hub is “active” on the API web interface.

I’ve rebooted the hub, reinstalled the app, logged out, logged in. Nothing’s working. So frustrated.

I’m on iOS with a V1 hub. Same problem. Everything works but shows offline in the app. Two days now

Thanks, all. At least it isn’t just me. Now we can hope a fix comes along.

Same issue here, V1 hub, automations work, App does not work, Google Home control also does not work.

Is there a fix yet? or is it time to move to another platform?

Same issue for 2 days. iOS app, V1 Hub, Echo devices. The following steps from Smartthings customer service helped me. Probably they have fixed the issue for some.

  1. Uninstall and reinstall the SmartThings app
  2. Disconnect the power and ethernet cables from the Hub
  3. Wait at least 30 seconds
  4. Reconnect the power and ethernet cables
  5. When the Hub is back online, its LED will turn solid green

I’ve been having this issue for a few days now. My Zwave buttons and sensors and lights are working, but not the app. Also Alexa integration has stopped working.

The app and Google integration is still not working. I have a V1 hub and have done this process multiple times. The automations still work, motion sensors turn on lights etc.

I think it may be time to abandon ship.

I read on another thread to reboot the hub from the IDE, this appears to be working!

Hope this helps some others.

Confirming, reboot of the hub (v1) from IDE worked for me. Thanks @Aboxman!

API reboot worked like a charm (300 miles away). Why don’t they just send a reboot to all V1 hubs? Now if the new app would load up and show status in less than 40 seconds it might be usable again.

1 Like

Thanks for the IDE idea. Problem is, I went in there and had two locations. Got rid of the one with no hub, but I show 2 hubs on my account in the app, but not on the IDE. One is the active, one is the inactive creating the flag on the app. Only the active shows on the app. When I try to delete the inactive hub, I get an error mesaage