Hub frequent disconnections and deleted drivers magically come back!

Hi, All,

I’ve got a Samsung v2 hub which has been running well for many years. For the last many months I’ve been getting frequent “Your hub is disconnected” messages followed by “your hub is connected”, typically ~45 minutes later. I’m seeing this every four hours, give or take (no specific pattern). I waited to troubleshoot this until I replaced my router, but it’s now plugged in directly to the router (TPLink Deco) and I’ve tried multiple cables. My internet is fairly stable; outbound connectivity isn’t affected while the hub is disconnected. I have an uptime monitor set up at which shows 100% uptime for the last few weeks (based on pinging my router from an external site every five minutes), and a monitor running on a Raspberry Pi shows my outbound has been consistent (occasional outbound pings which don’t get responded to).

I have 25 total drivers, of which six are unused (Bose, Harmon Luxury, JBL, Philips Hue, SamsungAudio, Sonos). I’ve tried deleting these from the Advanced console but they always return - what’s up with that? Are these default drivers which can’t be removed?

Any ideas where else I can troubleshoot? I can set my RaspPi monitor to ping specific sites, anyone know what site the hub checks in with so I could ping this manually?

Thanks for any ideas…


You are correct that these drivers can’t be removed. You can remove them but they will return within 24 hours. see the following thread:

As for your hub disconnecting… you should definitely contact ST support and let them investigate. I could probably suggest a couple of things to try such as a soft reset of the hub that resets the network settings on the hub or change the dns servers on your home router. But Support is probably a better way to go.

soft factory reset by following these directions:

  • Disconnect the power cable from the Hub
  • Using a pin or a small tool, hold down the reset button on the back of the Hub
  • While continuing to hold down the reset button, replace the power cable
  • When the LED on the front starts flashing yellow, release the button

soft reset only wipes out the network settings of the hub. Soft reset does not affect devices or routines.

Note: release the reset button once you see flashing yellow. If you continue holding until it becomes a solid yellow then everything is wiped out - a full reset.


I got the following response from Level 2 support:

If the hub shows a blue LED, then it isn't connecting through the user's network. The user will need to
troubleshoot their network to find out what's keeping the hub from connecting. This can include
firewalls, security settings, or even an excess of network connected devices which can limit bandwidth
to the hub and keep it from connecting. For further network assistance, we recommend the user reach
out to their network support.

The only step left from the ST side will be to replace the hub with a new one.

I only have a single router between the hub and the internet, with no firewall restrictions. I can’t imagine what could cause occasional inability to reach the Smartthings servers other than some issue with my ISP (Xfinity) which isn’t showing up with any other sites.

Is there any way to determine what server my hub is trying to reach? If so I can at least try a traceroute or such while the hub is disconnected and see where things are getting stopped. My router (TP-Link Deco M5) doesn’t provide this level of monitoring so I can’t extract the server name or IP from router logs. Is there a standard server which US Smartthings hubs contact?