SmartThings Community

Hub Firmware Release Notes - 25.32

hub_firmware_update
(SmartThings) #1

We’re excited to announce the release of Samsung SmartThings Hub firmware version 0.25.32. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)

Release Date: 20 May 2019 ~ 22 May 2019

Release Notes:

  • Fix local automations triggered based on SmartSense Garage Door Multi open/close events
  • Fix an issue where manual changes of older Z-Wave switches are not detected immediately
  • Fix loss of communication with secure Z-Wave devices after soft factory reset
  • General Z-Wave bug fixes and improvements
  • Improved boot times
  • Local support for the SmartThings Arrival Sensor
11 Likes
(Denis Anderson) #2

Does this update also apply to the Shield TV version of Smart things?

(Jimmy) #3

No, only V2 and V3 hub models listed.

#4

I sure hope this resolves things like this:


and

Both of those are “older” GE switches, but I also have a none zwave plus GE Fan Controller doing the thing. This happens daily for me. Pulling the airgap switch resolves this 100% of the time.

Oh but wait, I’m already on this version of the firmware! lol

(Bob Kerr) #5

I am not sure if I asked you before, but have you tried changing the DTH in ide to something else, update, then a few minutes later update back to a local DTH?

#6

I haven’t tried that since these are using ST’s stock handlers. I suppose I could change them to something like the “zwave device” DTH and back again, but I’m not sure what that would help with.

The funny part about all this is that while the IDE says they’re offline, control through Alexa or SmartApps works fine, but just not the ST mobile apps. Alexa does come back and say the device isn’t responding, but she still executes the command and the device does change to what I told her to do.

(Bob Kerr) #7

That’s why I suggested flipping the DTH. Call it superstition/coincidence but after each new firmware update, I get at least 3 or 4 devices like that, and changing the DTH fixes them every time. I never turned off my Device Health, so having sensors listed offline is really annoying.

1 Like
(Allan) #8

Awesome! And well overdue. Now what about the stock “Z-Wave Fan Controller” you guys released that is now the default for things like GE fan controllers? This is still cloud based which doesnt make much sense since you can flip it to a stock z-wave dimmer and it will be local (but not as pretty).

(DLee) #9

So what you’re really saying is this firmware update is mostly targeted to undo the damage from the last firmware update…

5 Likes
#10

I tried your method, and sure enough as soon as I switched to “zwave switch generic” and than back to “zwave switch”, my 2 switches that were offline are back online again. The mobile app still wasn’t able to control them though. I may not have waited long enough, but I’ll try again.

1 Like
(Bob Kerr) #11

Oh, that is a very odd symptom you’ve got going on, which makes no sense. If they show online and you can control them via Alexa and other smartapps but not mobile apps, that I never seen before :frowning:

#12

Has anyone with V2 hub had significant issues since this update?

Just about all my devices have dropped out and cannot be re-added after removal and resetting. This includes smartthings devices. In fact the only ones still operating are 3rd party.

(jkp) #13

This update has not been released yet except for the beta testers :slight_smile: at least in the U.S., it hasn’t

1 Like
#14

mmmm, sorry I saw the email regarding the update while I was away and on my return I started having issues. Put 2 and 2 together and made 5.

This does however confuse me even more. I’ll keep digging, cheers.

(DLee) #15

Quite often platform changes seem to precede hub fw updates. And quite often the result is devices freezing/locking. Happens to me every few months and aligns with ST side changes every time. Both Zigbee and Z-wave can be impacted which leads me to believe some changes are not deployed in a nondestructive manner.

1 Like
(Gabor Szabados) #16

Any chance this has fixed the buffer overflow issue from a large picture causing the hub to disconnect
as reported by @RBoy and me?

1 Like
(Otto Mation) #17

I assume that based on the first post that this is now rolling out and so far there has been no screaming. This is a good sign.

1 Like
(יונתן גרג'י) #18

There is no improvement for me with this firmware release. still many devices (Fibaro double switches and dimmers) randomly unresponsive, and showing prolonged delays while remotely operated and also many errors in the Z wave repair. I had many interactions with the smartthings team, some of them helped for a short period but nothing last for more than few days. I belive there are major problems with the smartthings hub firmware and cloud causing this instability. It’s not device related because the problems are random and can be relieved temporarily.
I wish I could hope for a solution but i’m starting to give up on this platform.
very dissapointed.

(Nick Dennis) #19

I think my Schlage lock is not really communicating with smart things anymore and it’s worked for about a year. I changed the batteries and it’s really glitchy, I lock and unlock the door and half the time it updates in smartthings app and sometimes it doesn’t. I also now have zero control to lock and unlock the door with smartthings app. Would hate to factory reset the lock and go through the mess of setting it up if it is because of this update. Very frustrating >:frowning:

(www.rboyapps.com - Make your home your butler!) #20

Did you try adding a repeater close to your lock? It makes a big difference in the quality of the mesh and reliability of your lock communications. What you’re describing sounds like it can benefit from having one. Also as a temp measure try to reboot the hub and do a Z-Wave repair.