Hub Firmware Release Notes - 19.17

Yeah. They said my hub was faulty and they’re sending me out a new one. I get to rebuild my entire system now. :slight_smile:

Sorry to hear that!

Shxt. Aren’t you the lucky one… :rage:

I’m going to go both unplug and remove the battery to force a reboot… Will be back with an update… augh…

not sure what happened but power cycling did the trick… I am now 19.17… :smiley:


FYI: For anyone using Mobile Phone for Presence on Android only!

So I was part of the Account Migration Beta program (a month ago) and as part of that Beta, I had updated my SmartThings Mobile App to version 2.10 (it was coincidentally released at the same time as the beta). Anyway, as someone who had never had an issue with their Mobile Presence in SmartThings, my mobile presence stopped reporting, period. So after trials and tribulations, I eventually deleted my Mobile Phone from SmartThings and then added it back in. The problem was solved by doing this and my mobile presence began working again without a single issue.
So with that, I didn’t chalk it up to any one cause as the issue. It is now in the past. Or so I thought.

That’s is until Friday of last week. My Motorola Z Force had a radio failure. I could no longer get WIFI to turn on. Even Factory Reset my phone. Nightmare, not so much, but definitely an inconvenience (everything, apps, contacts, photos, etc backed up). So I was shipped a new phone 24 hours later.

After restoring everything to this new phone and reinstalling the SmartThings Application on my phone, I had to run some errands and realized that I didn’t receive a notification that zForce had left and my ST didn’t Arm. Anyway, I began troubleshooting this in depth when I got home:

  • Looked at Mobile Phone in IDE - Showed INACTIVE (guess this would be accurate considering old phone was factory reset and powered off)
  • Went into ST mobile app and moved my Geofence about 10 miles away. Saved
  • Turned logging on, looked at Recently. The device shows Last reported date of the 14th. The last time I arrived home

So what I did was goto the Market Place and add Mobile presence again. Now the way this works, is if you have already added your Mobile device to SmartThings, you will receive an error stating that it already exists (if device is identical).

Now because this is a new phone, it has a different mac address, etc and when adding whatever device fields are read in, I’m assuming the uuid that gets inserted into Network ID are based from the phone itself, being able to add the new phone was expected.

After adding this new phone into ST, I then named it similar to the existing oh one in ST. I then looked at old phone in Things and went to Smart Apps tab. I removed the old phone and added new phone to every instance right there in the Smart Apps tab.

  • Looking at this in hindsight now and what I wish I had tried first was taking the UUID from the Network ID in IDE given to the New phone and copied/pasted into Network ID of existing phone, and then immediately deleting the new phone from ST. Hindsight is 20/20 and lack of sleep and beers.

Anyway, moving forward:

After performing the steps above and getting all Routines and SmartApps updated and reflective of the new device, I did the following:

  • Went into Geofence and moved it 10 miles away and saved
  • This did not result in the phone reporting that I had left
  • So I took a drive about 15 miles away.
  • Still didn’t report anything or change the device status.
  • I gave up and went to sleep or passed out depending on how you look at it.
  • Fired up coffee, sat down and opened ST and first thing I did was move the Geofence 10 miles away.
  • Ding ding ding! zForce has left Lake House!
  • Set Geofence back to default location
  • Ding Ding Ding! zForce arrived at Lake House!

Why this took so much time to report, I have no idea, but I’m going to say patience plays a key role. Anyway, I left the house and everything Armed appropriately. Got two blocks away from the house and everything Disarmed and garage opened as expected.

Because of so many issues across the board reported everywhere over a very long period of time, I wanted to give a very detailed description of my 2 situations and maybe this helps others that experience the same thing in resolving rather than screaming and yelling at ST:

Troubleshooting details:

Existing Phone:

  1. You are running Android
  2. You have always had reliable Mobile presence
  3. You upgraded to 2.10 or 2.10.1 of the ST Mobile app
  4. Mobile Presence stopped reporting period


  1. Goto Geofence setting/map in ST App
  2. Move perimeter 10 or more miles away from your actual location and Save it until you come back to Dashboard page.
  3. Wait a minute (this depends on notification settings you have for the Mobile Presence (mine is set at one minute). If you receive notification (if you have it turned on for device, or if you goto to things and see if it sets your phone to Away, then you are golden.
  4. If above was successful, then go back into Geofence settings and press the button in the map that resets the perimeter to your current location (lol obviously do this while you are home) and Save. You should be good to go now. Goodbye!
  5. If it still doesn’t report, goto Market Place and try to add the phone again. It should error on you as this is a duplicate device.
  6. If it does allow you to add it, follow step 3 down under New phone below
  7. If you do receive the error, I believe that you will need to Remove the current phone (take a snapshot of everything you have the current device added to before deleting).
  8. once you delete the phone, go back to Market Place and add it again. Immediately repeat the steps for the Geofence procedure steps 1-4.
  9. If it doesn’t report, exit out of ST and wait a couple of hours and perform it again (this the patience part)

New phone:

  1. Do not delete your old phone
  2. Goto Market Place and add your new phone from Things / Sensors.
  3. Login to IDE and copy the Network ID from new phone
  4. Paste Network ID into current/old phone and save/update.
  5. Delete the New Phone added. ( You may have to copy the Network device to notepad or somewhere else first, delete this device and then update the existing one with that Network ID as I didn’t get to try this procedure as it was an after thought)
  6. Go into the ST Mobile app
  7. Repeat Geofence steps 1-4 above Under existing Phone instructions up above.
  8. If the device doesn’t Notify or show as Away after a minute or two, wait a couple of hours and try again.
  9. If this doesn’t work, then change the Network ID you just pasted to 123456 or something else other than what the new phone was.
  10. Then go back into Market Place and add the New Phone again.
  11. Follow the procedure I documented in my summary up top about going into the SmartApps tab under Things of your old/current phone and add new phone and remove old phone from every Routine and Smart App.
  12. Then Delete old phone
  13. Repeat procedures for Geofence again and if it doesn’t immediately report wait a couple of hours and try again.

Sorry for the lengthy book. Just wanted to be able to help someone out step by step to save them from as much pain as possible.

The End


Meant for that post to be posted under the 2.10 thread. Too many windows open :). Going to leave it here as well. Will copy to the other thread as well.

My hub was recently updated to 000.019.00017

If I loose internet connection, I can’t connect to the hub via my home wifi … kind of a problem if I get home and want to disable the alarm.

After this update, as others have mentioned…the “Uptime” of the hub is stuck at 32sec

and I have posted a couple of times in regards to the Uptime field…

My hub works again, thank you ST!!! I went in and re-set up active tiles on my wall tablet, Alexa is working, and most devices are as well, so happy!

1 Like

I would ignore this uptime. They replaced another value that was stored in there before and it was incorrect as well. Mine is at 35 from the day of the firmware upgrade and outside of that, I have 0 issues, so that thing is just an annoyance that I would ignore.

1 Like

That is great for you but I broke one of my outside lights. Please try to remember not everybody is the same.

Just stating that the beta team had very little problems. Dont start taking it out on me.
Moan at SmartThings either not having enough in the closed beta team or not offering a open beta once the closed beta finished.

1 Like

It’s always fun to shoot the messenger :slight_smile:

I love the fact that the post doesn’t contain a quote and is referring to a post way the f up there, hehe.

He’s just frustrated. Gotta blame someone


I’m still having major hub crash/reboot problem since 19.17. My hub has logged 9 reboots in the past 12 hours!!!

Support has been so far been able to help. Ticket #450928 is open… This firmware update has turned out to be a train wreck for my system. The nastiest of the events over the past 12 hours kept the hub non-responsive for 11 minutes while it rebooted several times.

Please check your even logs and reference my ticket if you see any random hub disconnected messages followed by zb_radio_on and zw_radio_on events.

In the case of my hub, it appears that these hub crashes are usually preceded by a Z-Wave power cycle event.

Finally I have local processing. I use a mix of Hue lighbulbs, Aeon Multisensor v6 and Aeon minimote. To make multi sensor compatible I am using v5 instead of v6. Any idea what is the difference between two device handlers?

Any plans of giving more customization to Smart Lighting smart app? One of the use case I have is motion sensing lights but depending on the time the brightness changes. I am not able to do it locally so still using webcore at the moment.

Will be great if one can have a local processing decision engine

It creates a proliferation of entries (which drives be to webCore), but you can accomplish this in the Smart Lighting app by creating more than one and assigning criteria to make them mutually exclusive.

1 Like

Expanding on what farlicimo said, you can get a similar effect with SmartLighting currently you just have to make a couple different rules. You can use turn On and set level, and then specify only run during specific times. You have to create a different rule for each different level you want to support, so it is certainly not ideal if you want a lot of variability, but that is how you could get it to run locally currently.

1 Like

@Zach_Varberg, @tpmanley its nice to see that more and more devices now runs locally.

One thing that I dont have been able to find is a DTH that works local with a secure dimmer, If this becomes available I will be able to get all my light automations to run locally