Hub Firmware Release Notes - 0.24.11


#409

Even if this was the case this should have never happened, he has only always had 1 hub and 1 location. He is going to contact support after the second time because it is a pain to have to re-pair everything. This should also not be a “common issue.” This mentality that we should just “accept” these issues is exactly the reason why I left ST.

Forcing updates to the hub and then completely ignoring your user base when they have issues is really poor customer service if you ask me and it seems to be getting even worse.


(John C) #410

It did. Again.

Sleepy device probably tried to check in during the outage @jkp spoke of, LOL.


#411

Had a GE z–wave outdoor switch fall off the network in the past week (just noticed today). Been rock solid, not 1 problem ever in 2 years, and just dropped off today. I was able to reset it via some lucky combo of button presses (manual has no instructions for reset) and get it added back. . . .but seems like funny timing given this thread’s comments on z-wave devices flaking out.


(Younggunna777) #412

I can confirm the harmony z wave dimming issue is there still as well.


(Kevin) #413

Oh hey look… Once again more ST sensors with just a few weeks old 2450 button cells saying 1%. Yup thanks for quality updates that either burn through batteries, or epic bad reporting code. Ive quit replacing them since they all still read very close to 3v when I do replace them. And I’ll bet by tomorrow it will be at least 22% or better now.

And just had a Cree randomly turn off lol. Not flash or anything, just turn off and nothing in the activity feed on the app. Yup.

I love this latest patch…


(Eric) #414

Wow. I’ve been a SmartThings user for several years now with virtually zero issues. Suddenly all of my GE devices are ‘unavailable’, along with a handful of Aeon switches and contact sensors. No combination of using ‘Replace’, and pressing manual buttons is restoring the connections. This is extremely frustrating.

Other devices are taking unusually long to change state after a command. I’ve tried everything. Rebooting the hub, cutting power to devices, etc. Nothing is working. sigh

Edit: Upon further investigation, it seems the problems are only z-wave devices. I tried a Z-Wave repair, but that returned error messages ‘can’t update mesh info’ for the offline devices. I also can’t seem to exclude and re-add them. Is it possible the z-wave radio is bad?

RESOLVED Edit: Started pulling batteries on the contact sensors. Suddenly all the Z-wave devices connected and started working. Guess it was a bad z-wave device crashing the z-wave network. I slowly added all the batteries back, and everything is 100% working now. Guess I know where to start troubleshooting if this happens again.

Sorry for posting in the firmware release topic – must have just been a coincidence.


#415

Perhaps, but unlikely considering how bad this firmware release has been. I’m not saying you may not have a bad device, BUT battery powered zwave devices are NOT repeaters, so they wouldn’t have an impact on your GE’s coming back online.

It’s not coincidence. This was a terrible firmware release and you’re just now seeing it.


(DavidK) #416

I understand that for some this firmware was not well. But for others there were no issues.

I think it is possible for a malfunctioning device to flood the network with traffic and cause communication problems for other devices.

I have seen this with Ethernet devices. For example a malfunctioning laser printer causing problems for a whole subnet.

My only concern is that if someone is having a problem unrelated to this firmware, but just assumes it is the firmware, their issue will never be resolved, as they are waiting on a fix that will never arrive because their problem was not this firmware.


(Kevin) #417

If it was a bad device here and there could you say this many people have devices flooding their home network? I’ve been a professional sysadmin for 17 years now, and in that time I could count on 1 hand how many times its been a device flooding the network. Despite how many times I’ve had consultants tell me its a device flooding, it never has been.

I am one of those people that ‘never has issues’. I occasionally will post about how little issue I have… most say no way its possible. But I go months without an issue of like ‘oh change a battery’ and thats only because I have sensors on every door, window, room, and even outside. This firmware update, mostly of the devices, has given me more issues in a month than I’ve had in almost 3 years of constant ST usage. I’ve survived many of the ‘great downtimes’, some of the other bad patches, and even the zigbee cree bug I found. Yet this has me actually considering changing how I do things cause its been that annoying.


(Bob) #418

I agree. Mine is now turned off. Going on ebay soon.
Has anyone actually heard anything from ST as to what is going on or are they all doing Ostrich impressions because that is how it seems to me.


(Sully) #419

I’ve kept my mouth shut for fear of giving my hub any ideas… but I haven’t had the issues folks have been describing ( only a few delayed actions, and a couple of missed events over the past few weeks). I went to poke around and see if I could figure out what might make my setup different. The only thing I’ve found so far is that I have OTA firmware updates turned off.

There was some minor problem several versions ago that made me turn it off, with the plan of turning it on for a few days after each update. I obviously forgot that plan, but in this case, that seems to have spared me some of the issues other folks are seeing. Whatever is going on, I think it must be directly related to some OTA firmware update that was pushed out with the hub update (which seems to be the prevailing theory at the moment), but thought I’d share just to add a little more info to the pile.


(DavidK) #420

Same here, jinx!

I have OTA on, heath check on. I had one device which had an firmware update drain its battery while it got the update.

But since I changed the battery everything else has been fine.


(Kevin) #421

I preach that keeping the system as ‘stock’ as possible helps reliability. I dont run any custom DTH’s, no custom apps, and even run everything as default as possible. It’s been very stable. But even me doing that has still caused issues. One thing we all forget on this forum is that we are the 1% of the users of ST. I’m sure the old stated ‘most users have less than 15 things’ is still very true and maybe its lower now. So me at like close to 100 things in the house is not ‘normal’.

I just like my house to ‘just work’ and it did up until a month ago. Most of my stuff still ‘works’ but the battery issue has been the biggest issue for me. And I’m normally one that has been complaining the most about battery reporting in ST.

One of the things I hate the most tho, is just the radio silence we have gotten from this. Even if we just got some lip service of ‘we are looking into things’ would do a lot to quell some of these thoughts.


(Mark) #422

This also bothers me.


#423

I couldn’t agree more! While there are users like @professordave and others that haven’t felt the wrath of this firmware release, as well as probably all the other ST customers out there (as mentioned above that we’re a very small population of their customers); but I can tell you it’s been painful. But, it’s getting better…

Something is happening in the background because I’ve noticed improvements over the last couple weeks, and then a slight dip down, as though ST is tweaking something.

Like I did a few posts back, I’ll jinx myself when I say this, but it’s been 2 days straight where I didn’t have devices go offline where I needed to get involved. My battery replacements have also slowed down. I only had 1 in the past week. Battery reporting has always been an issue for ST, and I have several support tickets with them on this, and maybe one day it will be resolved. What I wouldn’t mind seeing is something like what Blink has done, and instead of trying to determine a % value for a battery, just tell me high, medium, low or OK/Replace indicators.


(DavidK) #424

for zwave device drop off, is there any pattern with respect to brand or model of device?

And the drop off is a permanent thing? Smart things is no longer able to communicate with the device?

Are the devices losing their network ID or something? Did the device network ID in smartthings get corrupted?


(DavidK) #425

I did have a local app failure last night. Not sure what to make of it.

So main entry hall, rear hallway has smart lighting automations to turn on and off lights based on motion, locally running. Normally it always triggers and is instant.

One time last night, I was able to walk from main hall, through rear hall to rear bedroom and no lights went on. So smart lighting failure :frowning:

5 minutes later all smart automations then ran fine like normal. Walking through house and lights turned on with motion correctly.


#426

No. The majority are GE switches, but that’s also the majority of what I have. I’ve had Aeon, Fortezz, Zooz, and Leviton devices all exhibit the same thing. Pulling an airgap switch or throwing a breaker wakes them up again. Zwave or Zwave+, doesn’t matter. Most/many of these devices have been in place since 2014, and this is the only time I’ve seen this type of behavior.

Yes, see above.

Via the mobile app, No longer controllable. Through automations like Alexa or Smart Lighting, usually Yes. This debunked ST’s theory that this was isolated to old GE devices and a zwave firmware issue they have.

No and No.

Like I said previously, ST broke something for some users, and we’ll never know why or what, but something is going on in the background because I’m noticing things get better, or even revert back to problems that went away.

Additionally, I was part of all these betas, and until the very last 1 or 2 releases leading up to the production release, I did not have these issues.


(Lee Florack) #427

Agree with this. My z-wave thermostat has never (several years) been dropped from the network or even had any connectivity issues - until yesterday. Had to hit the reset button and look for 'new 'devices to get it communicating again. Very bizarre.

Fortunately, the Cree bulb issue hasn’t hit me because I turned OTA updates for lights off a long time ago.


(John C) #428

True, dat.

Simply not an option for an unattended location. My two hubs are in New England & Florida and I’m only in one location at a time…