Hub Firmware Beta 0.26.9

I’m seeing same thing here

Could it be platform/internet latency? That’s the hard thing to debug whether it’s local or remote latency.

1 Like

My latency is averaging at 33ms

:man_shrugging: In my case its a pretty simple smart lighting automation. motion -> turn on light. Looking in the event logs for both devices in the IDE, the set level command is only milliseconds after the motion event. To me that says it’s not a platform issue. Next time I catch it happening i’ll send in a hub log right after so the ST team can rule that out. Then all that would be left is internet issues. At least that’s how i’m troubleshooting it in my mind :slight_smile:

1 Like

I would be interested to see how ST takes a crack at this.
I’ve seen various scenarios

  • The command is “sent” but it takes a long time to actually reach the device using a custom DTH. However the same command using a local DTH works much faster, pointing me to a slow DTH execution
  • The command is “sent” but it takes a long time to reach the device, whether it’s local or custom DTH. This could be an internet delay or a platform delay in communicating with the hub or a combination. That’s what I would be interested in seeing how ST debugs this. If there was a timestamp from the hub when it received the message that we can see vs when the platform sent the request, now that would be AWESOME.
1 Like

remember to post on centercode :slight_smile:

1 Like

I am unable to exclude or include any devices into the system.

This is affecting both zigbee and zwave.

I’m posting in centercode now.

Please fix this…Lol

1 Like

If you’re using a custom device handler, try republishing it.

That’s not it.

Devices I attempted to exclude and join:

Iris smartswitch plugin
Leveton plugin outlet
GE outdoor plugin module

None of these are using custom device handlers. Which in this case doesn’t matter. The system is not seeing a new device at all. Nothing. Nada. Zilch.

rebooted your hub? :slight_smile:

Actually, no.
I haven’t rebooted that hub in over a year… lol
I’ll do that now.

That brought back the zwave… Sort of. I was able to add a device but I can’t exclude it.

Zigbee still isn’t working

Are you still having trouble adding devices?

Yeah, a little bit.
I’m working with Chris via PM on it.

I’d be curious to know what solves your issues. I have several zwave devices I’ll excluding tomorrow and replacing them with new zigbee switches.

1 Like

Hi everyone,

For the below reasons, I’d love the opportunity to test out beta firmware for the hub to see if this resolves my issue. I’ve filled out a beta application as well.

I’ve been having a ton of issues trying to add a Samsung Powerbot R9350 vacuum to my SmartThings. It adds and is detected in SmartThings, I can see device status in there like charging, cleaning, etc… but if I click on tjhe vacuum to bring up the vacuum menu which shows all the clean settings etc, it says “Connection Failure, Please check the power cord and connection and the network connection status of the device. If the device is consistently disconnected for more than a day, please register the device again by selecting add devices.”

I have already done this. I have rebooted my router, I have factory reset my SmartThings hub which was a painful process to set everything else up again. I have re-added the vacuum to SmartThings and the issue persists. This appears to be a known issue for several years running. I’ve also tried any troubleshooting steps listed in this link:


Hub firmware wouldn’t affect anything with the vacuum.

At this point, I’d like to try whatever options are available. The vacuum is supposed to connect to the hub, and the SmartThings app is then unable to properly bring up the vacuum despite showing status updates. The vacuum has an IP address assigned through my router and I can see it. I don’t know what the problem is but it appears to potentially be SmartThings related in some capacity.

I should mention that I can start and stop the vacuum through the tile in the SmartThings app, but tapping on the tile to bring up vacuum settings is where it errors out with connection error messages. I’ve tried logging into to see network commands issued to the vac, such as Google Assistant commands issued to start the robot, and the robot never receives them. It’s very odd.

Hub firmware 0.26.12 has been released for beta testing. Please refer to Hub Firmware Beta 0.26.12.