How To Join Existing Leviton Vizia RF + With USB Stick As Primary Controller


(David B Bitton) #1

I just received a new ST hub today. My exisiting Zwave setup is programmed using the Vizia RF + Installer Tool software and a Leviton USB Zwave stick; the stick being the primary controller. I would ultimately like to make the ST the primary, however I’ll settle for secondary. I tried using Include Device in the software, and then joinning the exisiting network from the zwave tools in the iOS app. The Leviton side never sees the ST controller, and the include process eventually times out. Is this at all possible, and if so, how? Thanks!


(Geko) #2

You can make SmartThings join existing Z-Wave network as a secondary controller. This function is buried in the mobile app and not easy to find. Go to the Dashboard and tap the menu (three horizontal bars in the upper left corner). This will open location menu (“Home” or whatever you named it). Now tap on the “gears” icon in the upper right corner. This will open configuration page. Scroll down to the “Hubs” section and tap on on the “Home Hub” (or whatever you named it). On the next page, tap “Z-Wave Utilities”, then “Join or Leave Existing Z-Wave Network”. Finally, tap “Join”. Now put your primary controller in inclusion mode and you should be set.


Smart Things as secondary Zwave controller
(David B Bitton) #3

I performed all of those tasks to no avail. Oh well.


(ADAM) #4

i think i have got it.

1 you have to reset up your system
2 reset all your switches and remotes
3 start by connecting one of your switches to the ST controller ( i think this starts a new network)
4 reset your programming remote or usb
5 join the ST system with your leviton programming device
6 you can program the rest of your system with the remote or usb and the ST controller auto populates all the switches that you add using the programming device. you still have to go and include all the controllers and switches.

i did have to spend a day reprogramming my entire system but this made the ST hub work with the leviton vizia RF. you can not program the Controllers with the ST hub you have to use the leviton programming device. but it all appears to work,


#5

I was able to add my hub to my existing zwave network, it shows and controls all of my existing devices however I see no way to add a new device to the smartthings hub. It doesn’t automatically add devices which were added to the existing zwave network after the smartthings hub joined. I also see no way to refresh a list of devices etc. Anyone have any luck adding a new zwave device after joining the smartthings hub as a secondary controller?


(George) #6

Has anyone had success with using a Leviton VRCPG as a primary controller, and getting the ST Hub to join as a secondary? When I try that, putting the VRCPG into “send data to secondary” mode, things time out. The ST Hub seems to create a new/different Zwave network rather than join the existing Leviton one.

I tried going the other route, with ST Hub as primary and VRCPG as secondary, but the “button controller” app did not recognize any of the buttons on the remote – so I gave up on that route.