How to add unlisted Z-Wave devices


(Tim Smith) #1

Hi all,

has anyone worked out the correct approach to add unlisted Z-Wave devices? I know I may need to write my own Device Type, but how do I add the device in the first place?

In the mobile app there doesn’t seem to be a way to “include” a generic Z-Wave Device.
In the Live IDE, I can’t add a device as it doesn’t have a Network ID yet.

I must be missing something here. Can anyone give me a basic walk through of what to do?


#2

In the mobile app click the Marketplace button then select “Connect New Device”. When the screen shows that it’s searching you should perform the steps to include the device.

If there’s not a device type for it it will pair as a “Z-Wave Sensor”. If you don’t see anything at all you’ll need to exclude the device and try again.

Thanks!


(Tim Smith) #3

Thanks Tyler,

not sure why, but I’ve never managed to see any unlisted devices offered to me using that process.

I’ve tried a Fibaro Door Sensor (FGK-101) and TKB Outlet Switch (TZ88E). I’ve Excluded and re included and then Excluded again in my current Z-Wave controller, so I know the devices work and Include/Exclude is working. They just never seem to show up for me in the Smart Things App.

on a side note, The Fibaro Door Sensor is on the list of supported devices for the UK, but isn’t a specific option in the App, is there any reason for that?


#4

I had a similar problem with a different device and the generic “z-wave door/window sensor” didn’t seem to appear in the mobile app either.

I got it to work in the end after much messing around, and the included adding my own “device type” in the ide. However, I am not sure if it was my unfamiliarity with z-wave exclusion/inclusion or the device type actually made the difference?

Anyway, if you are confident it isn’t the exclusion/inclusion malarky and nothing else works, then you can try adding your own custom “device type” ?

I checked the IDE and you can create your own device type using the “Fibaro Door/Window Sensor” template. Then restart (force close if required) your mobile app, and try adding it again…


(Mark C) #5

How did you include it in the end. I bougt a tz88 plug but i cant seem to get it into inclusion mode