How I Made Linear's GD00Z-4 Work with LiftMaster's MyQ Door Opener

Beginning of 2019, same issue with a Chamberlain/Liftmaster/Pro from 2012 (strange model number). SS->COM patch worked as described. Thank you, @mcavoya , for doing the legwork on this. Also very happy at the ease of disassembly/reassembly of the box - was a 5 minute project. I suspect this might also be the source of the problem with reviews of this model where it stops actuating after 6mths to a year - weak cap? That circuit needs to be revisited. Thanks again!

Well, after about two and a half years, my GD00Z-4 has stopped working.

Everything behaves as expected (door position correctly indicated, flashing light and beeping for ten seconds, etc.), except the relay does not close.

I pulled the GD00Z-4 and its sensor from my garage, and put them on my bench. I removed my jumper wire, and connected the relay contacts (the “push button” contacts) to a 5 Vdc supply through a series resistor.

Then I watched the SS test point with my voltmeter. When the relay contacts were open (“button not pressed”) SS was close to 0V. When I “pressed the button” (shorted the relay contacts) SS was close to 2.5V. So that monitoring circuit seems to still be working.

Next I watched the relay contacts with my voltmeter. My meter was set to VDC with the MAX/MIN function enabled. The meter normally shows 5V. When I used SmartThings to activate the door, I expected the MIN value to go to near 0V; but, it did not change. So the relay did not close.

One side of the relay coil is connected to +12 Vdc. The other side of the coil goes to a pair of transistors to ground. I used a small resistor to jump around the transistors to ground, and the relay clicked. So the relay seems to be functional.

Next I watched the base/gate of the transistors with my voltmeter. It normally showed 0V. So when I used SmartThings to activate the door, I expected it to go to some positive value. It does not.

I traced that signal all the way back to the processor. How do I know it’s a processor? There is a “PIC ICSP” programming header right under it. The red arrow in the following photo shows the pin that should drive the relay, and you can see the programming header near the bottom.

I peeled off the label (no point in worrying about warranties now!), but the silkscreen on the part had been buffed off. In any case, that pin always stays low. It never tries to close the relay. So now I have an expensive door position sensor.

My adventures with the GD00Z-4 have come to an end. I will not buy another. I’ll find some other solution. In fact, I have already started down that path.

I was annoyed that I could not use Google Assistant to open/close the garage door, so I wrote my own SmartThings device handler and app to convert a Z-Wave relay into a door opener. All I have to do is get my own tilt sensor, and update the app to behave like the old garage door app. You can find that project here: https://github.com/mcavoya/garage-door-button

I hope Linear figures out why the GD00Z-4 has so many reliability issues. Best of luck to everyone still trying to make it work.

I installed a UNIVERSAL SECURITY+ 2.0™ INTERFACE MODULE from Creative access solutions https://www.creativeaccesssolutions.com/Universal-Security-20-Interface-Module_p_13.html

It installs between the GeoCOntrol Linear door controller and the Garage door opener. It allows SmartThings to open and Close a MyQ garage door opener

1 Like

Hi there just thought I would confirm a solution the worked for me as well.
I think there are some threads above that cover this. I have a 8500w liftmaster and I used an 882lm switch for this

The nice part about this is you only risk messing up the 882lm that costs about $22

Chaimberlain 7675 MyQ GDO, I soldered direct to an old remote opener and it worked for a couple months, then fried the remote opener. I wired I another opener a few days ago and it fried within a day. Second one was compatible with any security protocol, had lots more chips on its board, maybe too sensitive. So I found this thread, I think I will try the original post’s trick soldering the jumper in the GoControl module, but In the multiple posts, I couldnt tell if that worked for sure for the MyQ openers… thanks everyone who took the time to share all this!

mcavoya - I know I’m very very late to the party, but I did want to thank you for the SS to COM short as it worked perfectly for me and made my GD00Z-5 fully functional with a LiftMaster 8500. Very much appreciate all the input you gave on the subject.

I’m always glad to hear when someone else can get this to work. I hope your GD00Z-5 lasts (much) longer than mine did. Have fun!

Hey mcavoya,

First of all thank you so much for posting this. I bought the the GD00Z-5 in correlation with my Chamberlain B730 Quiet Drive opener. Doing some R&D, it wasn’t on GoControl’s website of incompatibility. My old opener was too loud to be below the master bedroom so I swapped and read that the GoController was compatible with my SmartThings setup.

Like you and everyone else, I installed to spec. Got normal manual operations from the door, but the controller would only beep; no movement whatsoever. Calling the company, of course they tell me it wasn’t compatible with my Chamberlain because of the MYQ system. They told me that Chamberlain makes a proprietary system, I didn’t want it because it wasn’t compatible with SmartThings.

Some house keeping notes for those attempting this fix:

  1. Remove the entire circuit board from the housing and solder from the bottom.
  2. The wires that are used for the manual button and the controller are the perfect diameter to use for the “SS” and “COM” holes.
  3. Use rosin core solder. NOT ACID CORE!!

I did this at work tonight so I will update in the morning when I get home if this worked or not.

Those are great tips. I’ve been doing this for so long that it didn’t even occur to me to mention those details.

Update: It didn’t work. I just purchased the Security 2.0+ contactor. I will report back if it works or not. After that I’m just going to wire a spare remote and call it a day. I don’t wanna deal with this for months.

Thanks for the help though.

As an alternative to using the unreliable Linear GD00Z-4 to control a MyQ opener, have people considered trying this SmartApp? It unfortunately does have some hardware requirements (gateway or bridge, plus a tilt sensor), but at least those don’t generally and reliably stop working on most people.

1 Like

I hope you are still monitoring this feed. I understand your frustration in trying to make what should be a simple garage door opener function. Just looking for a little quick advice if you are still available.

I have two Liftmaster 3850P garage door openers with battery backup.
They are wired to the 398LM Smart Control Panel.
Remote is 315MHz Liftmaster 373P (three button)
I also have two Craftsman garage door openers that work fine, so the question is only for the Liftmaster 3850P.

We upgraded our security system, and Tech installed ZWave GD00Z-5 on all 4 doors. Craftsman models worked fine. Liftmaster with ‘Smart Control’ only beeped, no movement, so they were removed.
Installing tech initally told me there was no fix, then referred me to this site, and told me I might be able to make it work if I order 2 GD00Z-5 and ‘2 clickers’, go to this site and do some soldering.

I presume ‘Clickers’ are wireless remotes. Do I still need to do soldering on wireless remotes?
In reviewing the previous posts, it appears that only soldering the jumper from SS to COM fixed the problem, or am I missing something?

You are indicating that only shorting SS to COM worked. Did you connect it to a wireless remote, or wire it to the opener, or did you wire it into the wall mount controller (in my case, a 'smart control panel".
Thanks.

Shorting SS to COM made my GD00Z-4 (emphasis on the “-4”) work with my door opener without the need for any other modifications. My GD00Z was connected directly to the same wires that connects the door opener to the wall mount button.

Other solutions involve “isolating” the GD00Z from the garage door with an external relay or wall mount button. I suppose you could hack a wireless remote and achieve the same isolation.

Let us know what you try, and how well it works.

Well, I tried this trick but apparently my soldering skills are lacking… I seemed to have broken the switch remote when soldering the Linear lines to the switch terminals. :frowning:

Anyone out there a sharp shooter and willing to do this?

Since you have to re-connect the opener to this remote as well, are those red/white wires soldered on the other side as well (which is what I did)?

Thx.
Jon

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.