Honeywell Tuxedo and SmartThings Secondary Controller Issue


(Lee) #1

Hi Everyone,

My first post here though have been lurking for a bit. I’m hoping for some guidance. I have a Honeywell Tuxedo panel with the latest (as of today) 5.2.22.0 update. While the panel operates as a Z-Wave controller just fine, I am having a tough time integrating the ST hub as a secondary controller and importing existing Tuxedo devices.

Now, using either the IOS or Android apps, I can add the Hub which is listed as a Static Controller on the Tuxedo just fine, though initially states the hub is ‘Not in a secure network.’ After searching the device again it changes the status to Success. On the Tuxedo it has a lock icon next to it.

However, none of my existing Tuxedo Z-Wave devices populate on the ST apps. None.

Now, when adding the Hub to the Tuxedo, on the ST app itself, I never get a success when pairing the two. I only receive a success when removing the Hub from the Tuxedo (it states Success on the ST app). But when adding the Hub, while the Tuxedo might say success, the ST app just sits there playing dumb spinning around while stuck on Join/Leave. I can only assume it is added successfully because I can remove it with success. Perhaps a false assumption.

Any ideas on populating the existing devices from Tuxedo to the ST app?

EDIT: I noticed the SUCID on the ST hub is 01, should be 00 I believe, is there a way to force it?

Thank you,


(Jason) #2

Afaik this is set via hub firmware. A while back some hubs unintentionally had the 00 sucid (mine was one of them) they had to include the change in afw release.


(Lee) #3

Well, just an update for those searching and finding the same lack of answers as I have I went ahead and made the Tuxedo my secondary and ST hub the primary. Everything moved over just fine. The Tuxedo does for some odd reason display the Tuxedo as primary after a sync, but everything works fine on both controllers. When adding a device on the ST hub I just reset the Tuxedo and add it back as secondary and it updates with the new devices from the ST hub. Unfortunately, the names do not carry over to the Tuxedo.
So far so good.


(Loscabosav) #4

I am in the exact same scenario. Hopefully someone out there will help but me guess is that Honeywell is keeping this info private, for good reason so the ST does not control the alarm system which leaves you and your system vulnerable. Only really interested in controlling the Z-Wave devices and trust Honeywell as primary but unfortunately it looks like I will have to try to make it the secondary; Honeywell does not recommend making the Tuxedo a Secondary…

Update: I was able to delete everything, delete the ST site, delete all devices etc on both sides. Once I configured the ST Hub as primary and after adding in lighting, I was unable to correctly access or sync my Tuxedo through my TC 2.0 app… Had to delete everything again and start over using Honeywell as the Primary controller. Back to square one…


(George Novak) #5

Same issue here, but I never get a successful link message on the Tuxedo. The ST hub is no help, as it always says “success in joining network” even though it failed. I’m getting annoyed at the posts that say “Successfully joined the ST hub as a secondary controller”, but then they don’t give a good description of the process; and worse they only post once. I’m beginning to wonder if their success was just a fluke and then it stopped working.
ST is setting up an RMA as they don’t even support secondary controller status much less linking to a Tuxedo panel. I want to give it one last shot, so I’m hoping someone who has done this will post. If you can get me more info, I will document the process and report my findings. I just need to know how you got it to work and is it still working.
Tomorrow, I’m going to try to link the ST as a secondary controller, let it fail and do a rescan on the Tuxedo. If it changes to “Success” I will assume the ST is now part of the network (even though it didn’t get a device download". If I can get that far, I will try to add devices to the ST hub individually. I have some small GE ZWave controllers that have the same issue. The Tuxedo will add them into the network, but it will NOT download a device list. I believe this is because the Tuxedo panel will only download it’s device list into another Tuxedo panel. It’s probably a security thing or because the panel isn’t 100% Zwave compatible. Anyway, my GE controllers are now part of the network, but they don’t have a device list. I can verify this because the “all on”/“all off” commands work after I add them to the network. So, its just a matter of adding each device separately to each controller. Yeah it sucks, but my network is fairly static.
I’m hoping the ST hub will do the same thing. I will let you know what happens.


(George Novak) #6

Well, not luck adding the ST hub as a secondary controller.
I was able to get the “success” message on the Tuxedo after doing a ZWave scan, but I did not get any devices added by the pairing. I believe there are a couple of things going on here.

  1. The Tuxedo Touch really isn’t a good Zwave controller. It doesn’t play well with any secondary box that isn’t another Tuxedo Touch, and it wants to be the primary controller.
  2. The ST hub doesn’t like being a secondary controller, so even though you might be able to “add” it into the network; you won’t be able to add devices to it. Somehow it seems to think it’s not allowed to add/remove devices on it’s own, so it just waits for the primary to sent over a list. And since the Tuxedo isn’t sending a list, you are dead in the water.
  3. SmartThings doesn’t support this type of pairing, so future updates may undo any successful pairings or mess things up. I believe my updated Tuxedo software is causing the current issue, since other people seem to have made a successful pairing (along with device download). Maybe I can force the two to work together, but chances are that may get wiped during the next major update.
    So I’m sending back the hub and I’m going to wait till things get sorted out.

(Carmelo Joseph Rizza) #7

Are you able to control everything through The TC 2.0 app? Do all the scenes still work? Can you please give a more detailed explanation of how you did all of this? What firmware are you using on the Tuxedo?


(Robert Battaglia) #8

Hello Lee,

How are you able to make the Tuxedo the secondary. I can change it on the Tuxedo to secondary but don’t see any option on the ST app add it. I am sure I am missing something but there does not seem to be an option on the ST to add a secondary controller.


(shatzjim@aol.com) #9

I have a Tuxedo and ad ST Hub. I fought with integrating both of these for some time but finally solved the puzzle when I needed to add an additional device. All devices need to be excluded from the Tux and then included in ST. Then from the Tux, change to secondary controller. Then add device from both Tux and ST and they will sync. Unfortunately the names won’t pass from the ST but the system is finally working together. This would be a lot easier in ST had the ability to be secondary. Thanks to the folks at Inovelli for working with me on this.


(shatzjim@aol.com) #10

Use add device on both ST and Tux


(Phil) #11

Hello all
Wanted to know if the Tux and ST, integration has been resolved. I currently have both products working together, however I have added new zwave devices since the time I paired both devices. I believe I have the Tux as a primary and the ST as a secondary controller since I can not add any new devices to the ST but I can add them to the Tux.

I would like to know how can I sync all my new zwave devices so they can be seen on the ST hub.

If there is a write up already on how to make this work can you please point me to this information.

My issue is I am new to zwave and it has been some time since I initially set this up and have since forgotten what was done.