Honeywell thermostat issues with "new" app

went in to change my thermostat temp using the app for the first time since I was forced onto the new app.

there is no way to adjust the temp (this worked for 4 years on the old app) only see the current temp and history.

I tried to delete and re-add the device and now the app crashes every time I try to add the thermostat back in.


Which Honeywell thermostat are you referring to?

I know this don’t help, but this is what you should see. Using device type “Z-Wave Thermostat” on a TH8320ZW thermostat.

Only issue is you can only adjust the temperature one degree at a time.

Are you linking the thermostat using the newer “Honeywell Home Total Connect Comfort” (red 72 icon), not the older Honeywell TCC (thermometer icon). I have both and since the classic app shutdown the older one only shows temp, humidity, and history, no settings like you describe. The newer one will let you adjust (as in the screenshot) Downside on mine is the tile now says “connected” and not the temperature.

The older Honeywell smart app allows you to use the command “resume program”. The new one takes that away.

I have have this thermostat for 6 years on the old and new app.
No issues at all with the Z-Wave thermostat DHT provided by ST.
I use C so I get 0.5 degree steps. They are ever so smaller than 1 F :wink:

Honeywell Home Wi-Fi 7-Day Programmable Thermostat (RTH6580WF), Requires C Wire, Works with Alexa

this was the problem!!! thanks!!!

Actually if you tap on the temperature text it’ll allow you to manually enter a number directly.

Also for the Honeywell T6/T5 and other z-wave thermostats you can check out this enhanced z-wave thermostat device handler to enable the Auto mode on Honeywell thermostats. By default you can only select Heat and Cool modes separately, this DTH will also enable the Auto mode (apart from allowing you access to other features like locking the screen controls remotely etc)

1 Like