Honeywell Smart Wi-Fi Thermostat Compatibility

Not sure where to go from here. It could one simple change or twenty. The fact that your account is on a different host and you use a different app probably means you will need a different device type.

What is happening is the cert being returned by is not for that site, but for or one of the variants.

If you do a nslookup of you will see this as an alternative:

@Swapper can you try changing the URL to be

I just found this after I started my endeavor to create a PHP class for the API. So glad to see that I wasn’t the only one cobbling stuff together to get some control over the API and data therein.

Has something changed again recently? I checked the activity log and the last update was on Sunday, Nov 30th at 10:10pm CST. There have been no updates in the log since then.

I just installed the code for the app on the 29th. Should I expect more frequent updates in the activity log as I have the thermostat programmed using the Honeywell app to go down to 68 degrees in the evenings.


Not sure when I last updated the code but it’s working fine for me today.

If you want frequent polling:

Are you seeing frequent events in your activity log?

I’ll give this a try also to it if helps.

thank you, after getting this installed properly it works with the latest code. might be helpful to add a nice readme though, new users are going to have a really hard time doing this.

i have an upstairs and downstairs unit so i had to create two devices, but it seems to work great. is there any way to change the temperature icon to some text or text + temperature so i can tell the devices apart? Both say 68 degrees so I don’t know which is up or down without going into the device itself.

Can someone please tell me how to implement this code! I am on a Mac and a iPhone but am totally lost on how to do this code. Any help would be appreciated greartly. Thanks.

copy the code and go to new device type. paste the code in. then go to devices and add device. scroll down to the bottom of the list for what code to use, and you’ll see total connect API. use that as your device connection script.

then go to edit, then edit preferences (on the web management of ST), add your username, password, and device id. you can get the device id from the total connect webpage url when you click on your thermostat. its a 6 digit number at the end of the url.

Where in here do I put the info?
input(“username”, “text”, title: “Username”, description: “Your Total Comfort User Name”)
input(“password”, “password”, title: “Password”, description: “Your Total Comfort password”)
input(“honeywelldevice”, “text”, title: “Device ID”, description: “Your Device ID”)
And I also see this at bottom
body: [timeOffset: ‘240’, UserName: “$username”, Password: “$password”, RememberMe: ‘false’]
data.cookiess = ‘’

After you create the device type, you will create a device using that device type. The settings are entered when you are setting up the device.

  1. Paste code into new device type
  2. Create a device using that device type
  3. Fill in the settings with the information

OK let me get this straight after I publish the device type then during the device setup in the SmartThings app I enter my info, is that correct? Thanks, for the hand holding.

Correct. You publish the device type for yourself. After that, you can create a new device. Fill in any random number for Device Network Id. After the device is created you can edit the preferences section with all of your info. Good luck.

OK the device ID is any number I want correct? Also I have to have the HUB installed before doing this correct? My hub is in the mail as it died. Or can I just choose Home as my location?


In My Devices (IDE) use any number for the Device NETWORK ID.
Use the 6 digit number at the end of the URL for your Device ID.

Thanks, that helps a huge amount. Now I have to wait for the hub to arrive.

first is there any way to change the label on the main tile to say upstairs or downstairs instead of either shaking the phone or showing the temperature?

i see value tile of temperature but its 2x2 after i enter the device, but i’d like to remove the temp on the device button and make it the device name.

second is it possible to make the device tile clickable to enter the device instead of the gear on the icon?

@isriam, while I don’t have the wifi version, I do have 2 Honeywell thermos that use my own device type for each to do what you’re asking. In the value tile definition for temperature, I tweaked it like this for each floor:

state(“temperature”, label:‘1st:\n ${currentValue}°’, unit:“F”,

The “\n” is suppose to cause the temp value to be on a second line (carriage return), but is doesn’t work, as you can see from the image below.

1 Like

awesome thank you. i actually took both of my wifi thermostats back to costco and picked up a couple zwave ones. i’ll see how they work out. they work out of the box so far, which is nice compared to the wifi stuff.