HomeAssistant 0.87 integration

So it seems like this is live now and although the version of HA itself has some issues, the ST integration appears to be working fine.

It’s definitely much, much simpler than the previous approaches with the MQTT bridge, and it automatically generates all the devices and sensors on the HA side which can be controlled immediately via the UI.

The process is basically just a couple of steps:

  • Create a personal access token
  • Click on the new SmartThings integration in the HA web interface and enter the token
  • This automatically creates the SmartApp that you can just install from the mobile app
  • You’re done

When you return to the Integrations screen, you can see the configured ST integration in place:


Clicking on this shows you the state of all the devices imported from ST and their current status.

At that point you can start using these as devices in groups or using the payload for automations.

I must say it does offer a much simpler way of integrating both systems, so you can take advantage of whatever you might want to do in HA based on input from ST devices.

The single most useful thing that I’m eyeballing right now is the introduction of “Areas” in version 0.87, which allows you to specify areas which can be restricted to some users – so you can for example make the kitchen or guestroom devices available for guests via the web interface in a dashboard, without allowing them to control your bedroom / bathroom or some other devices.

Keep in mind that this implementation requires external access, so you still have a dependency on the internet even if HASS is local, plus it requires SSL. This is easy enough to configure using the DuckDNS add-on with Let’s Encrypt (literally takes a couple of minutes) so it’s not a big deal if you want to go that route. Rolling your own might be a bit trickier since you can’t use self-signed certs.


Good to know. I was getting ready to start dabbling in HA this weekend. My Pi 3b+ is on the way.

Is this done via a Groovy Smartapp or using the new SmartThings API?

After entering access code in the Smartthings integration, I keep getting error “ Unable to setup the SmartApp. Please try again.“ any ideas why?

Thank you for this but where do we find the instructions to set it up :slight_smile: … without checking here first out of the blue i installed HASS on a spare raspberry pi just last night so it will be nice to integrate??does it read and control ST devices or ST reads and controls HASS??
Like i said brand new to HASS haven’t even searched the forum for a ST and HASS integration yet

When I pressed submit button. Nothing happen:(


Same here. Generated the token and when press submit i get the error: “Unable to setup the SmartApp. Please try again.”

For anyone that’s having problems… Sorry? :slight_smile:

Seriously though, I don’t have any more info into how this works or whatever solutions might be out there. I just followed the instructions and “it works on my machine.” :slight_smile:

The docs are light on configuration but I’d imagine any issues are from the lack of ssl, a missing base_url or maybe something along those lines. I’d start there and / or ask in the HA forums for assistance.


Guess you were right…Base_url was missing. Now it’s working. Thank you

1 Like

yup missing the base_url and ssl…
but after that i still have error after input token “Unable to setup the SmartApp. Please try again.”

I managet to fix “Unable to setup the SmartApp. Please try again.” :slight_smile:

  1. Enable “Two-factor authentication” in Home Assistant for your users (Not mandatory but recommended)

  2. Open port 443 in your router and forward it to your Home Assistent server port 8123

  3. Install and configure DuckDns

“lets_encrypt”: {
“accept_terms”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
“domains”: [
“seconds”: 300

  1. Configure HTTP in configuration.yaml

api_password: YOUR_API_PASSWORD
server_port: 8123
base_url: https://YOUR_DOMAIN.duckdns.org
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

  1. Don’t install “Let’s Encrypt”, DuckDns handel it for you :slight_smile:

  2. Install SmartApp “Home Assistant” in SmartThings Classic

  3. You are done :+1:

1 Like

One thing I’ve noticed is that there’s the occasional clash between the systems.

ST will turn some lights on due to motion, and a bit later they’ll get turned off for no obvious reason. I’ll have to check the logs and see, but I think HA might be enforcing whatever state it thinks the lights should be in, and turns them off.

I guess this wouldn’t be a problem if I was using HA as the primary to interface to ST for the nice UI.

I might have to poke at it and see if there’s anything else that might be going on, because it’s obviously annoying when you have things happen that are not supposed to – more so than the other way around, I guess :slight_smile:


I dont use DuckDNS and the SSL is correct (ios HA app validated) but still “unable to setup…”

@lctang, is your ssl self assigned?

1 Like

thru synology let’s encrypt
also i have 2 hub one is US connect pro , one is V2 UK

I tried installing Hass.io (v2.8) but running into boot issues on a RPi B+. The ACT light stays OFF a few seconds after boot. Hassbian however is working on the same SD card, setup, etc. Is the ST integration with Hassbian similar?

adding a new device to Smartthings hub requires delete integration and add again? I added a Fibaro Roller shutter to ST and is not updating on HA. i’ll delete the integration and smartapp, and add again see if it works.

Yeah I haven’t tried to see how that works, but obviously adding a new device to a third party like WebCore or sharptools requires that you re-authorize and allow access to the new device.

Maybe there’s a way to reinstall or configure the SmartApp that would allow this, but I haven’t played with it yet.

1 Like

@kmugh I have setup Hass.io virtual on VMware, working great

@Xicoamaral, did you tryed just with HA restart?