HomeAssistant 0.87 integration


(Francisco Amaral) #21

Yes, still no luck… I’ve deleted smartapp, deleted integration tried and now i can only access 2 off 3 devices that i have… i cannot add fibaro fgr-222 to HA. But it works flawlessly on ST…

This is “normal behavior” of the smartapp?


(Javier Dst) #22

Now I have the same issue. It was working fine before the last update.

Any clue?

Thu Mar 14 2019 17:12:29 GMT-0300 (Argentina Standard Time)
Error processing webhook 2c4e834439134b8e63f5811d82cd680a0bf6417987be4cf959ed1b12b0c9a4ea
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/webhook/__init__.py", line 85, in async_handle_webhook
    response = await webhook['handler'](hass, webhook_id, request)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/smartthings/smartapp.py", line 335, in smartapp_webhook
    result = await manager.handle_request(data, request.headers)
  File "/usr/local/lib/python3.7/site-packages/pysmartapp/smartapp.py", line 173, in handle_request
    raise SmartAppNotRegisteredError(req.installed_app_id)
pysmartapp.errors.SmartAppNotRegisteredError: SmartApp handler for installed app 'd1d6004e-1c5c-444f-b5f9-e6725c94f7e0' was not found.


Thu Mar 14 2019 17:12:19 GMT-0300 (Argentina Standard Time)
API error setting up the SmartApp: {'requestId': '0C62B642-C8EE-4004-8DF7-2ED42686F8F9', 'error': {'code': 'UnexpectedError', 'message': 'A non-recoverable error condition occurred.', 'details': []}}
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/smartthings/config_flow.py", line 87, in async_step_user
    await app.refresh()  # load all attributes
  File "/usr/local/lib/python3.7/site-packages/pysmartthings/app.py", line 355, in refresh
    data = await self._api.get_app(self._app_id)
  File "/usr/local/lib/python3.7/site-packages/pysmartthings/api.py", line 164, in get_app
    return await self.get(API_APP.format(app_id=app_id))
  File "/usr/local/lib/python3.7/site-packages/pysmartthings/api.py", line 370, in get
    return await self.request('get', self._api_base + resource, params)
  File "/usr/local/lib/python3.7/site-packages/pysmartthings/api.py", line 365, in request
    data=data)
pysmartthings.errors.APIResponseError: 500, message='Internal Server Error'