Help with Z Wave Dimmer Switches after v3 Migration

I migrated from v2 to v3 - the v3 hub is connected via ethernet (could not get successful connectivity using Wifi).

I have reconnected smart apps (Google Home, Alexa and irobot) and many smart plugs. I cannot connect any of the my Z- Wave dimmer switches. I have several brands (GE, Linear, Leviton, etc.). I cannot get ST to recognize them.

I have attempted to exclude and included with no success. ST simply times out searching for the device. The Leviton flashes confirming that it is in pairing mode, but ST will not recognize/pair with it.

Any suggestion you may have is MOST welcome!

1 Like

If you are using the STSC app, try installing the Classic app and see if that resolves the issue.

1 Like

With the V3 in the new app, you have to pick a specific device to pair. Can’t just choose the add button. You can confirm the hub is in pairing mode when the green light in the front is blinking.

Hi JKP - thank you for your response. I have tried it with both ST apps, same results. I’m clueless as to what to try next.

When you try to exclude/add, do you continue to press the toggle on the switches every 10 seconds or so until they pair or do you only press them once?

I have tried both ways, but mostly I’m pressing more frequently. The one Leviton switch has a light at the bottom. When you press and hold the top of the switch for 6 seconds, it flashes amber then red and amber before it goes green. Once green I stop pressing the switch. I have tried excluding and pairing during all phase of these steps with no success.

The other switches I have do not have the lighting feature for pairing so I have no idea if it is the switch or ST, I’m guessing ST.

Have you been able to connect any z-wave device yet to the v3 hub? If you login to IDE at https://account.smartthings.com and look under my hubs, does the z-wave section show functional and your region is correct?

Hi JKP - It appears it is connecting to z-wave devices. Here is a paste from the IDE:

  • State: Functional
  • Home ID: DA1FCCBD
  • Node ID: 01
  • Suc ID: 01
  • Protocol Version: 5.03
  • Region: US

LOL just saw @RBoy post to another user. Try rebooting your hub and running z-wave repair :slight_smile:

1 Like

I rebooted the hub and then clicked the Repair Z-Wave Network in Utilities. I think clicked " [Z-Wave network repair initiated - Click to view progress’ But nothing displayed in the event list.

I tried to pair the switch again…no luck…

Did you ever get the switch to exclude?

I was able to exclude it (was not successful with that before the hub reboot). But it is still failing when attempting to pair.

My event log shows a completed exclude, an include start and then a ping. The phone displayed the timeout message. I tried pairing using both apps (v3 and Classic)

thank you for helping

stick with classic for now. Can you confirm the hub is flashing a green light when in pairing mode?

Yes, the hub is a flashing green light when trying to pair. I was able to successfully pair a Z-wave door lock, but it does not work with the switches…ugh…