Help! Routine failing to execute

Hi all, fairly new to SmartThings and am having an issue. I have the Aeotec hub.

In my kitchen I have 20 hive tuneable spotlights and have created various routines for them from turning on/off to changing the brightness and colour temperature.

The issue that I’m having is that about 50% of the time the routine will not execute fully, ie one lamp will stay on or not change colour temperature.

There isn’t a particular logic to it, I.e not one lamp always failing to change.

Any advice would be much appreciated.


Are you trying to do all 20 lamps with one routine? If so, it’s probably timing out before they all get done.

Try putting them in scenes in groups of five. Then you can try putting all four scenes into one routine and see if that improves things. If it doesn’t, you may need to use multiple routines. :thinking:

Thanks, will give this a go and feedback. Cheers

1 Like

Just to add I was triggering the routine with all 20 lamps via a virtual switch controlled by Alexa

1 Like

So I’ve tried running multiple scenes within a routine and multiple routines all with a maximum of 5 devices. It’s better but there is still the occasional lamp that doesn’t respond…

1 Like

I’ve had issues with seemingly lost commands in the past. My solution was to both break into smaller scenes and trigger each scene with a 5 second pause via an Alexa routine. I’ve also, in some cases, run thru all the scenes twice within the routine.

I noticed there was an option to do a delay when controlling an individual device in SmartThings routines now. Unfortunately no “standalone” delay or delay for scenes.

Not ideal for all cases but it’s worked for me.

1 Like