HELP needed to pair WEMO with Samsung Hub V2

i send this to samsung but no much hope. maybe i have better luck here

i have a V2 hub paried with a motion sensor and a WEMO light switch to turn on porch light at night from 5pm to 5am

the motion sensor can turn it on just fine, but all day long, not just within that specific time. this is my first problem , so i tried to solve it by resetting everyting , includeing the hub , switch and try to repair everything

now the real problem comes, after reset the v2 hub, i have no way to find the WEMO in ST, Alexa can find it pretty quick and works with the WEMO well, but no ST.

my Hub is a V2 hub with lastest 24.11 Firmware, i have follow the instruction to do a reset by pressing the reset key for 30 seconds and reentered the welcome key, Hub itself is online, but just can not find any other
WIFI devices, except the Samsung motion sensor which is zigbee…

appreciate any comments , i am new to smart home maybe i have done something stupid

You may have to do a reset on the WeMo and then retry the discovery:

  1. Unplug the WeMo .
  2. Hold down the reset button.
  3. Plug the WeMo in.
  4. Release the reset button a few seconds after it starts flashing amber.
  5. Once the WeMo is flashing amber and green the reset is complete.

many thnaks Sir
my WEMO is a in wall light switch and i have followed the instruction to reset , also the HUB
but after the reset, everhting broke,
alexa still work with this wemo, also the WEMO apps, just not ST

also , i tried to pair a brand new WEMO smart plug, still can not find the new one .
so sounds like something broken in the Hub

here is the update, in case can help someone running into similiar case

i kind of fixed this, by adding a new location , the default location is “HOME” and can not be deleted
so i add another “MYHOME” and add the hub into this new one, while delete everything in the “HOME” location
and boom everyting shows up .

here is the guess
my hub comes with an older FW so after i setup the switch, it went thru a FW update, and after that i did some unsuccessful RESET, probably the HUB permantently store the devices paired on an older FW somewhere and when next time on a newer FW , trying to discover these same devices, HUB just will not report them since they are paired, although not showing in the list .
just a wild guess but anyway it works now,