Help! My android no longer works for presence (Solved, Nevermind)

I had to reset my phone on the 15th and now my presence is stuck at home. Is there a permission I am missing somewhere? How can I get it to work once again. My wife’s phone works fine. I did have to do the roll back from version 2.2.2 and have not upgraded since. (Here’s is on an older version)

Make sure to update to v2.2.3 of the ST app. Second, if you did a factory reset on your phone then you need to add it back to ST as if it was a new phone. Do that before removing your old phone in ST so you can go through each SmartApp you have configured for the old phone to move to the new phone.

How do I add it in?

Found it, under “Sensors”

1 Like

Install ST app, then go to things… add thing…sensors… presence sensor … mobile phone

I did all of that, Updated software and added phone as new device. The new presence still registers me at home 35 miles away.

An added point of interest in this matter is: Every time I open the app to check presence, it shows “Arrived at [now]” but there is nothing in the recently tab or in the item logs at

Never mind, I had to turn on “Google Location Services”. Who knew?

1 Like

Can’t believe you missed that

1 Like

You also need to authorize ST for background data and location. Otherwise, you are right it will only update your location when you open it .

Where is that setting? I cannot seem to find it.

In your phone settings, where depends on what version of Android and brand of phone.

Galaxy S5 android 5.0

By default it should be on unless you’re roaming and you’ve set up restrictions or disabled data while roaming. You can find the settings for restricting background data this way:

  • Settings
  • Data usage
  • and then scroll down to the app you want to restrict and turn on “restrict background data”. By default it’s off.

Found it. It wasn’t restricted.

I would have been very surprised if it was. I’ve never had to authorize ST for background/location data. I have had to turn that on when I travel out of the country, but never while in my “home” cell network.