HELP! - Is ZWave that bad?

Okay, so here is the deal.

Bought my first ST Hub V3 (no previous hubs) three days ago. Currently only have three devices. (2) Kwikset Contemporary ZWave Deadbolts and one Remotek outlet. All three are able to pair with no issues. One lock and the outlet are in my living room. The other lock is on the front door with clear view to my living room. I’ve placed the Hub everywhere…In the middle of the living room…Near the Outlet…near the locks…everywhere. For argument’s sake. My living room is about 15 feet by 15 feet…The Outlet is against the exterior wall shared with my Back Door Lock approximately 10 feet between the two. The front door is direct line of sight from the outlet approximately 25 - 30 feet away.

No matter where I place the unit, I can’t get the devices to pass a ZWave Repair. Yes, everytime I moved it, I tried a repair and everytime, I get the following:

Z-Wave network repair started
Network repair for Living Room Light [03]:
Failed to update mesh info
Network repair for Back Door Lock [02]:
Failed to update route
Network repair for Front Door Lock [04]:
Failed to update route
Z-Wave network repair finished.

And when I say near one of the devices…i’m talking within 5 feet.

Yes I’ve completely reset my locks and reassociated them with ST.

I even thought I must have a bad hub, so I returned it and got another one…Same issue.

Today, at one of the locations I had the Hub, I got a clean bill of health from Z-Wave Repair. Once. And it stayed up for no more than 10 minutes before all the devices fell off and since then, I can’t get anything to respond.

Can anyone help me here? I’ve been working on this for about three days now (approx. 4 hours a day) and I’m near my wits end. I really want ST to work for me, but I can’t for the life of me figure this out and I’m a software developer for god’s sake. A consumer device like this shouldn’t be that difficult to get it up and running.

I was running insteon several years back and had great luck with that, but I just bought a new Family Hub (Samsung) refrigerator and it gave me the bug to try out HA again. I’ve gotten a ring doorbell, and Nest Thermostat and was able to integrate both of those into ST seemlessly. It’s just the Z-Wave devices giving me the red a**!

Thanks in advance.

There’s thousands of Topics on this forum, though check the FAQ Category, as that’s one of the best places to start to understand the particulars of mesh networking in SmartThings.

You’ll get various suggestions on this post.

My suggestion? Start by removing and excluding the locks from your network. Locks require a secure join protocol that is different than regular Z-Wave stuff, and that introduces some complexity that you should avoid while troubleshooting.

I have a Schlage lock that dropped off my Z-Wave network a few weeks ago, and I just haven’t bothered to try to re-join it … because I have to be prepared to deal with the consequences of Z-Wave repairing and so on.

But wait… you say… This is all about getting my locks to work!

Too bad. First confirm that Z-Wave works find around your household with a couple of powered devices and a couple battery devices (e.g., contact sensor, garage tilt sensor).

Then… if the Kwikset lock doesn’t work … try another brand.

In other words: My recommendation is troubleshooting by process of elimination. SmartThings does not provide detailed Z-Wave diagnostic tools, mesh network mapping, etc., etc., … so that’s what we do instead.

Okay…I removed ALL devices from the hub…then added back just the one outlet.


Should I assume that these devices are just dead and order a new light switch and a new outlet to test with at this point?

I hate throwing good money after bad, but am willing to give it another shot.


As as side note…

The three ZWave devices I’ve mentioned were working fine with my Vivint Alarm System at MUCH further distances just one week ago…

I have unpaired them from the vivint system before moving them to the SmartThings controller.


1 Like

What do you mean by “nada … zilch”??? Do you mean it fails to pair?

If so, then run Z-Wave Exclude exclude first on your SmartThings Hub and follow the exclude instructions on the device. If a device even thinks it is still in another network, it will not join to SmartThings until excluded.

No…It pairs just fine…but repair shows Failed to update mesh info…

It’s the only device on the network and it’s 5 feet away.

Perhaps just “Z-Wave repair” is broken.

SmartThings has been rather frequently updating Hub firmwares… with less than perfect consequences. I’ve
read from time to time that Support tells customers to avoid using the Z-Wave Repair function. But clearly that’s not sustainable as your network grows.

Why do you need a repair with only a few devices?

Regardless: If you are frequently getting repair issues, then your hub or one of your repeater devices likely has a serious issue (hardware failure, or flaky firmware).

Zwave is fine. SmartThings is flaky. :scream:

Multiple people reporting similar issues right now, unfortunately.

To troubleshoot, put the devices back on Vivint. If they work fine there, you’ve identified the issue.

One other possibility…you didn’t give the model number for the Remotek. It may not support beaming. SmartThings is finicky about that, so a different model zwave pocket socket might also solve things for you. See the following FAQ (this is a clickable link).


Sorry, I got distracted for a minute. (My dog had minor surgery yesterday and he’s keeping us both up.)

If we assume you are not being affected by the platform flakiness that’s hitting some people right now it sounds like the pocket socket is defective. (Of course putting it back on Vivint and seeing if it works there would diagnose that.) so trying an alternative pocket socket is also worth a shot.

If you live near Home Depot or Lowe’s they both carry GE zwave devices these days. Not my favorite brand, but you could try one and if things still don’t work it should be easy to return.


Just a heads up…I brought the ST Hub and the outlet to my office today and hooked it up and all worked great!. So obviously something wrong with the signal in my house.

I have no cordless phones and no baby monitors. No WIFI Routers on the first floor (where this was set up). The only thing I can think of is that maybe the old Vivint controller is still broadcasting and causing interference some how. I could remove it completely, but I’m not yet unhooked from them (should be within 30 days). All the Z-Wave devices have been removed from the Vivint controller, but I can’t find anywhere to disable the z-wave radio all together. Any Ideas? The panel below is the one that I have.

Interesting. I’m glad you found out the devices are OK, anyway. Wi-Fi doesn’t interfere with zwave, just with zigbee.

It could be the Vivint controller, although that’s pretty unusual. ( I have four different brands of zwave controllers running in my house right now, no problems. )

I don’t know anything about the Vivint controller specifically, maybe someone else will.

1 Like

It’s the hub. I had that problem as well as ghost devices on the network that support was not able to remove. Replaced hub and all is well.
On the other hand, if everything is working now, just enjoy it.

1 Like

Good solid advice from everybody, I’ll give you the weird idea, which is my setup.

I have all GE switches and a Kwikset lock. all z-wave. No problems.

The difference is that I got ADT Pulse (the original stand-alone z-wave hub, not the ST combo) before I heard of ST. All my stuff is hooked in on that.

What sucked is that ADT’s skill for Alexa isn’t a Smart Home skill, so I had to say “Alexa, ask ADT to…” for everything. Lame.

Then I researched and learned (from JDRoberts posts if I recall) how to make ST be a secondary hub. So I ordered an ST gen2 and did it. No problems. ADT does the heavy z-wave lifting, ST passes devices to Amazon, and Alexa, ST app and ADT app can all command the devices.

How’s that story help you? You said you have a Vivint hub. Still have it? Great. Make it be the master and join the ST to it (if possible) and your problems may diminish.

I have no idea if ST has a crappy z-wave radio or something. But unlike everybody else, my rig has run problem free for over a year.

The clunkiest part is adding new devices. ADT auto-discover works. Then I have to look up the device number (in hex) and convert it to decimal and then manually create the same device in ST with that number. ST only auto-discovered during the initial pairing to ADT. Not hard to do.

I’d look into testing just a simple switch like Tgauchat says. And try a GE switch, those things are rock solid, as jdroberts says. Then try my idea if those don’t work (presumably because ST’s radio is the problem).

Thanks for the kind words. :sunglasses:

I do need to clarify just one point, which is that at no time have I ever said that GE switches are “rock solid.” They are actually my least favorite big name brand. They tend to have weird and quirky device failures. And they use older commandsets with fewer features than some of the competitors. So I don’t use them myself and I don’t recommend them. But they are very popular because they are cheap, widely available, and a well-known brand name. If you like them and they work for you, that’s great. But they have a higher failure rate, probably 15%, and that is true whether you use them with SmartThings or not. They are still worth it to a lot of people because of the cost savings, but again, not my favorite brand. Lots of discussion in the forum on this:

These days there are two other brands, both with better engineering, in the budget category that I would suggest looking at first: Zooz and Inovelli.

JMO, of course. :wink:

1 Like

Any pointers on Zooz vs Inovelli ?
I am in the market for a few switches and was tending towards Zooz. GE is out 'cause I don’t want to buy 2 switches if I can make do with one. Did not consider Inovelli till I read your post, 'cause I really do not see it being mentioned in this forum much, but I do see it show up on Amazon every time I search smart switches. \ I am absolutely amazed by your knowledge in this field, I am willing to put my money on whatever you think is a better product. :slight_smile:

I suggest you start a new topic called “Zooz versus Inovelli?” And see what responses you get. Both are quite popular devices among community members, and it would be interesting to see what people have to say. :sunglasses:

I’ll be happy to join in just what I see from an engineering standpoint, but I don’t use either in my own house, so some first person experiences would probably be more useful.

Well…I can officially close this thread. After adding additional devices (light switch, outlet), my problems have stabilized!!!

All my devices are now working perfectly. The two kwikset and remotek devices are still a little slow, but I feel they will get better the more devices I add.

The new outlet (wired) and the Light switch (wired) are zwave plus and they are almost instantaneous.

Thanks all for the help!