Help..Hue hub now not working

Hi all…I was trying to delete old apps from smarthings , and tried to delete HUE B SMART…it failed with a network error.
Now all lights are missing from my samsung app, although they and the hub all show in the IDE ? and they all still work in the Hue app >
Tried to RE-ADD the hub as a device , but that also fails…
any ideas anyone…this is a real mess. !
Much appreciated. !

progress …(a little ) would you believe even though it would not add a device called Philips Hue with Smarthings hub
it DID work when I selected Philips Hue without smarthings hub…go figure !
It found all the bulbs, …but now the HUE HUB itself is no longer listed in the IDE…(I guess its added the bulbs individually ? ) Thats a little inconvenient, as its not picking up lighting groups now from teh Hue Hub…I will have to create them in smarthings…
Still cant delete HUE B SMART even now… its like a lottery !
If anyone knows how to gat this back to normal, where the hue hub is in control, please let me know. !

When you switched to Philips Hue without SmarthThings hub - it changed from a direct connection to a cloud to cloud integration so that will explain the hue bridge not showing in IDE.

Those are not currently available (to my knowledge with either of the two official hue integrations.

To remove the hue b smartapp, you would need to remove all the hue devices first that it installed, then remove the hue b smartapp within the ST app in the Automations section. If it does not appear in the main screen, click on Add Routine, tap the Discover tab, scroll down to the custom smartapps section. After that is removed, you can remove the custom code in IDE for hue b.

The hue bridge needs to be on the same subnet as your ST hub. You also may need to press the button on the hue bridge when you start the add device process in the ST app. If still not found, restart your router.

I imagine the reason it was not discovered was the hue b smartapp that was installed and currently connected.

There is also a community developed Edge Driver for Hue that you can check out.

thanks SO much for the detailed reply …all that makes total sense …I now see that I have 2 of each bulb, one showing as Hue B Smart Bulb the other as placeholder (which is the one working)
So I can go through and remove all the Hue B bulb references I guess and then hopefully can remove the app…
To be honest I installed Hue B Smart such a long time ago I forgot it was even there till today . !
Everything is on same subnet …the Hue button press was having no effect despite pulling and replacing the Lan cable to the hue hub.bizarrely it just sat there with 3 blue lights - even when the Lan was disconnected !
I also tried a power down/up of the Hue hub…
will try a router restart , and also that driver you have linked which looks promising
Again really appreciate it…will report back.
all the best