Help doing a simple Hue setup in ST?


(Jeremy Krall) #1

Currently we have a number of ST devices throughout the house and its working great, but we also have 4 Hue bulbs as well. All I want to be able to do is control them from the ST app and be able to schedule on/off times, movement responses, etc. And at the very least to see them in Things and be able to turn on and off. Can someone provide the best and simplest way to do this? We are fine keeping the Hue hub connected as well, just want it managed from one place.

Thanks very much!


(Jeff DeWolfe) #2

You need the Hue hub in order to add them to SmartThings. In the app, hit the + to add a device. On the list of things, look for lights or something to that effect. In that list should be an option to select Hue. Run through that and it will do a discovery to get them added. Let me know if you run into any issues.


(Jeremy Krall) #3

So I started this last night and it just say there “Searching for the hue hub” and never returned. The hue hub and ST hub are literally side by side. I am assuming I need to press the hue button which puts it in its discovery mode, but it never seemed to return. Is there an additional firmware update needed (I am running latest public version) for Hue?


(Jeff DeWolfe) #4

You do need to press the button, but the app will tell you when you need to do it. No additional firmware updates that I’m aware of…at least nothing that I had to do. How long did you let it scan for the hub?


(Tim Slagle) #5

Any sort of port security on your network? That might be getting in the way if their is. I had this problem.


(Jeremy Krall) #6

So tried again in detail last night. I hit Hue bulb to connect and then it takes me to the hub setup screen where it says connecting can take 5 minutes. I let it sit for more than 5 minutes and nothing. There is a Next button on this screen (which makes no sense if it hasn’t found the hub), but pressing this takes me to a screen that says press the button on the Hue. I tried this as well but same result.

No security on the network and the devices are literally inches from each other. Any other ideas?


(Tim Slagle) #7

Not sure. Have you contacted support?


(Jeremy Krall) #8

No, next stop obviously but I honestly wanted to make sure I was just doing it right :wink:


(Jeff DeWolfe) #9

Sounds like something weird going on for sure. You are following the steps I took when adding it…


(Ron S) #10

What I did with all 13 of these is to first get them connected to the hue hub first as and when I bought them And then bring up hue connect and then it brings up the bulbs…it takes a few minutes but it does including lux, living colors and bloom.