Help! 2gig go control will not learn


(Kenneth Foringer) #1

So I’ve scoured the forums here and a few other HA sites and cannot for the life of me get this stupid panel to act as a secondary to my ST v2. ST sees it as a controller, but the panel just sits for hours saying that:
“The panel has entered z wave learn mode. The panels current z wave controller type is: Primary”

ADC only had FW version 1.12 to push over the air to me, so that’s my current FW version. Anyone have any insight?


#2

Nortek is one of the largest manufacturers of zwave devices in the US. They sell their devices under different brand names. Two gig is intended for professional installers. Go control is their DIY brands sold at retail. They are usually the same devices, with the same model number, just in a different box.

There are some community members who have successfully managed to add a two gig controller as a zwave secondary to SmartThings, but the process has been complex and time-consuming. And, most importantly, it required knowing your installer code so that you could reset the panel.

I honestly have no idea how the DIY model handles the installer code. if there was one that came with it in your user guide, then the same method should work.

Let us know if that works for you, and if so, what you used for an installer code.


(Kenneth Foringer) #3

I performed the above steps previously but my results were what I mentioned in the first post about the 2gig panel seeming to get stuck attempting to learn. My panel has the default 1561 installer code. The system was originally a vivint install but a switched it over to ADC.


#4

Then I would ask in the other thread. That will flag the people who do have it working and hopefully someone will be able to help you.


(Kenneth Foringer) #5

Success!
Out of frustration… I rebooted the 2gig panel and ran a z wave network check. My devices are now populated correctly. Thanks for the help!


(Charles Praigg) #6

My issue is that I cannot figure out how to set the 2gig as the Secondary Controller. It always shows as primary, even after following these steps. Is there a menu setting somewhere?


(Kenneth Foringer) #7

Mine did the exact same thing. It would hang while doing discovery and always show the current setting as “primary”.
I removed it completely from ST and started fresh. Went though all the steps with the ST hub sitting on top of the 2gig panel. Let the 2gig sit there in discovery for about two hours (always showed “primary” and never moved on to another screen). Rebooted the 2gig panel and did a z-wave network check. Then went right to the z-wave devices in the 2gig and all of my devices were there.
The 2gig will still occasionally tell me that the ST hub has failed but it seems to all be working otherwise. It’s not the most seamless integration, but given how “walled off” the 2gig go control panel is… I can’t complain too much.


(Robert Wolski) #8

I can get all the devices to show up in the 2gig go control and on smartthings. I can even name the same device differnt names, in this case a outlet named Christmas tree, so I can easily turn it on and off with alexa.
Is there really a need for the 2gig to be secondary? Would it help in my quest to turn on my hue lights if the alarm goes off?


(Kenneth Foringer) #9

My working solution appears to have only been temporary. The whole thing crapped out when the update happened and now I’m back to square one. Still cant get it integrated as a secondary and now I cant get any devices to populate.


(Jody Tipton) #10

Mine is doing the same thing with the 2gig 1.17 firmware. It will show as secondary and I can see it in ST but after 10 minutes it resets back to primary.


(Kenneth Foringer) #11

I ended up giving up on this. It would work for a day or so, but always
ended up failing and trashing my whole mesh in the process.