"Heat" in Ecobee is Not Appearing as a Mode in SmartThings

Hello,

“Heat” in the ecobee is not appearing as a mode in SmartThings. all (Auto, Cold, Aux. heat Only and Off) are available except Heat (which is for heat pump). It appears to be a persistent issue with the SmartThings app, as it is unable to recognize the system mode for Heat Pump Heat. Can someone please provide a solution or a workaround

Thank you,

Ecobee supports the cloud->cloud integration so this is something they would need to investigate as to why that mode is not available in the ST app.

As a workaround,if you have a voice assistant that supports an Ecobee integration (like the Alexa skill), you can use a virtual switch in ST as a proxy to trigger an Alexa routine with a custom action to set the heat mode. I use this method because Comfort Settings aren’t exposed in the ST app either.

1 Like

Thank you for the workaround. Yesterday, I reached out to ST support, provided a few screenshots (to demonstrate that ST can detect HEAT as the thermostat mode, but it is not listed as a mode), and they assured me they will address it (add it to ST).

2 Likes