Ecobee Integration no Longer supports Auto Mode?

First, please no comments regarding paid integrations.

Second, it seems the standard Ecobee integration no longer has a “Auto” mode, only “Cool” or “Off”. This has broken an automation I have.

Mine still has that. Using an ecobee smart thermostat pro (5) with Alexa built-in.

Mine has an ‘Auto’ mode, but no ‘Emergency’ like above. The temperature display on the details page is still reverting to Celsius though, which is super annoying.

I have the Ecobee 4.

Really strange. I used to have it, now I don’t.

I just went through the integration again and unchecked this thermostat and then went through again, checking it. For a brief moment “Auto” showed up, but then disappeared again.

Mine has that because it’s an all electric system with a heat pump. The emergency heat is the furnace electric backup when the heat pump can’t handle it. So not all will have that option.

I don’t see any type of heat mode in your screen capture. I don’t believe you should have auto as an option in the modes if you don’t have heating as well. Auto to me, would be for automatically switching between heat and cool.

If you’re referring to the fan control, that’s not technically a mode.

Thanks for pointing me in the right direction. While troubleshooting an issue a few weeks ago, I believe the tech turned off the w1 connection in my Ecobee wiring. Strangly, ecobee itself still allowed me to pick “Auto”.

Turning w1 back on enabled “Auto” in SmartThings again. Interestingly, SmartThins also shows “Emergency” now, but I do not have an electric heat strip in my air handler, just the heat pump itself.


From what I’ve read, w1 shouldn’t be required for heating as o/b controls the first stage heat pump. So the question, remains, why do you need “Aux” heat in order to have the Auto or Heat mode in SmartThings? Maybe there’s something I don’t understand.

So, my ecobee app shows Aux in lieu of Emergency, which is actually the same thing. Just different terminology.
If you’ve got a heat pump, you’d have Aux or Emergency as well. Without the “heat” enabled, you won’t have either show up. Now if you have no heat pump, it should just default to show traditional"heat" mode.

That’s not true here in Southern AZ. It doesn’t get cold enough for long enough to need anything more than the heat pump. My downstairs unit does have the aux heat, but we’ve never needed it which is why I opted not to get it when I replaced my upstairs unit which rarely even runs in heat mode at all, let alone needing supplemental heat.

The fact that the ecobee itself shows “Heat” and “Auto” when no w1 connected seems to support that.

Interestingly, I disabled w1 again on the ecobee and SmartThings still shows all the modes. Maybe it’s cached, we’ll see. I opened a ticket with ecobee as well.

Excellent point! I’m an old HVAC installer, but never made it out of the Midwest where the idea of a heat pump at all took a lot of convincing for many years.

Back to the same issue again. SmartThings no longer allows me to select “Auto”, only “Cool” and “off”. I got a cryptic email from their support, I’ve replied back and am waiting for a response. I think there’s a bug where if you do not have w1 enabled, SmartThings thinks it doesn’t have heat.

1 Like