Having Trouble While Installing The Smartthings App on Windows 11

I have tried to install the app on Windows 11, but I am having a problem when installing the app. I am getting an error message “The application was unable to start correctly (0xc000012d). Click Ok to close the application.” But I have no idea why I am getting such kind of error. Could anyone please help me to fix it?

Which app are you refering to ?

From the web

The new OS only natively supports Amazon’s Appstore and not Google Play Store. And while sideloading Android apps is an option, anything that requires Google Play Services will not work. However, you can install Google Play Store on Windows 11 to overcome this limitation .

As with all things Windows… dont count on anything working as you would expect

No, I was trying o download the app from Windows 11 derectly and the download link is Redirecting - Popular Apps for PC

But anyway I have resolved the issue with a little help of this guide. The tasks which I follow first, I run DISM and SFC scan and updated the device driver. After doing the tasks properly, I have not getting any such kinds of error message which I was getting before.

Then I opened Microsoft store and from there I downloaded the app. Actually sometimes I need to open the app from my PC, so I tried to download it from here. Anyway thank you so much.

1 Like

I was bored so i thought i might install ST on my Pc from the Windows 10 app store, downloaded fine but getting it to sign in was clunky at best, after a few attempts ST finaly signed me in on the app but … its not full featured yet and fails to load Devices and scenes, all i see is spinning wait dots, Favourites seem to load ok

EDIT
And as i typed the devices and scenes loaded, took approx 17mins for them to show up… and it appears nothing happends if you click a device on off icon… or it might happen in 17 mins which is why i am not clicking anything other than 1 item

I had downloaded this app from the Microsoft store as well and had no success with it. I discovered that the app was not signed and that a VirusTotal scan has it listed as malware by 3 scanners. There are indications that this app could contain a reverse shell or RAT based on some of the files it creates.

There is no indication of a PC app on Samsung’s page so I’m thinking this could be a copycat app.

Could either one of you check on the app that you downloaded to see if it contains a signature? Was this app even written by Samsung? I’ve asked Samsung about this and submitted a case to Microsoft as well. Pretty sure neither will care about it (as is always the case).

It never worked for me properly so uninstalled