Has ST removed some camera integrations?

Hi all,

I’ve not added anything to ST for a while, but using both the old/classic ST Android app and the newer one, I’ve found all you can add is an Arlo or Ring camera? What happened to the Samsung camera additions?

I’m trying to add a Samsung Smartcam HD PRo camera I used successfully in the past in ST but now I can’t. Also trying to add a Wyze camera too but that’s a different issue.

Anyone have any ideas? Manual add?

Those have been gone for a while. Some people have had luck with support adding the option back. But I’d be surprised if that happens now.

That is disappointing. I’ve been out of the loop for a while, is Smartthings dying off? I remember the Lowe’s system went under, but is ST going the same way? I’ve tinkered with HomeAssistant and that OpenHAB thing but the support for that is so non existent you’re on your own

I don’t think so. In the middle of several transitions, but Samsung seems committed and has some cool features coming this year if they deliver. They actually have a newer camera out now.

1 Like

I was only able to add the new Samsung SmartThings Camera using the new Connect app. After that, I could then use the camera in the old Classic apps SHM custom configuration to trigger recordings from other sensors, but even though the recording was triggered from the old Classic app SHM, the recording clips can only be viewed in the new Connect app. Hope they add the Custom ability with camera support to the new Connect apps STHM so that camera stuff isn’t so fragmented.

What exactly are you looking for? New app STHM can trigger recordings, as can the automation creator in the new app.

The old SmartThings Classic app’s SHM has a ‘Custom’ section. In the Custom section, I can setup any sensor (motion, multipurpose, vibration, etc.) to trigger capturing video from selected cameras.

Example of Classic app’s Custom SHM feature; if the front door multipurpose open/close sensor opens when mode is away (Armed, Away) or night (Armed, Stay), then it will start capturing video on the living camera. That way the video recording will start capturing video before anyone is sensed by the living room camera’s built-in motion sensor alone.

Another example; the old app’s Custom feature doesn’t require the system to be in any Armed mode to do stuff, so it could even be in Disarmed mode, and the video recording could still be triggered. That way I could have the system Disarmed, and still trigger recordings so you can capture the Landlord or a contractor inside when your away.

As for the new SmartThings Connect app’s Automation creator, all I see is that I can turn on the Arlo cameras and nothing else. Only the SmartThings & my old DLink cameras offers recording. And the new app’s STHM, it’s not granular at all since I have to select all cameras to start recording irregardless of the sensor that triggered it, and I have to be in Armed (Away or Stay) for it to start recording anything. So, they just have to include Arlo cameras recording in the new Connect apps Automation creator and I could then use it.

1 Like


I contacted support about the Arlo cameras not showing the ability to record in the new apps Automation like other cameras. They had me remove Arlo as a connected service and then re-add Arlo to connected services. Now the Arlo cameras are showing the ability to record as an Automation action. NICE!

1 Like

Great news!

Well, a day or so after I had the record option available for Arlo cameras as an Automation Action in the new SmartThings Connect app, the feature has disappeared. I’ve tried to remove and re-add the Arlo connected service like I did before, but the Arlo cameras still do not show the ability to record as an Automation Action or Scene in the new SmartThings Connect app. It was there one day and gone the next.

So I went to the Android app and re-tried the ‘Smartcam HD Pro’ SmartApp under ‘Automation’. It found one camera, accepted the camera password and seemed to setup fine. It shows as ‘active’, and the reboot / recycle buttons make the camera actually reboot but when I hit ‘play’ on the screen it says ‘video format not supported’. Is this a side-effect of Samsung not supporting these cameras anymore? Is it still possible to get this working as I did about 2 years ago?