Harmony not updating in ST app

I posted this is ActionTiles community, but I think it’s more appropriate here. So I want ActionTiles to have the ability to Turn OFF Harmony remote activities. No further abilities needed. Since it cannot connect to AT directly, I created a virtual switch in IDE. Then I created 3 routines in ST:

  1. Turn ON the virtswitch, when any of activities a, b, or c, etc. go on.
  2. Turn OFF the virtswitch, when any of activities a, b, or c, etc. go off.
  3. Turn OFF any of activities a, b, or c, etc., when the virtswitch is turned off.

(Routines 1 & 2 are designed to keep the virtual switch in sync with whether or not any activities are running. Routine 3 allows me to put an AT button into tileset which will actively turn off harmony activities.

The problem: When I use the regular remote control (or Alexa) to turn ON an activity, that activity should go ON in the ST app -> Which would then trigger the routines -> which syncs the virtswitch to actual device status… But I cannnot figure out why the activities in ST app are NOT going on as they should. The physical devices (tv, fios box, etc) are going on as they should, but the status isn’t getting reflected in ST. If I go into ST App -> In the harmony activity’s options, when I hit the ‘manual refresh’ button, it DOES update to correct status (on) in ST (and therefore the routine runs and the ActionTile updates. Any ideas why I would need to manually refresh?? Is there another way others have accomplished what I am trying to do??

(Note: I wanted to do this is webcore instead of ST, but I couldn’t figure out how to write the piston with the options I was shown).

Is this in reference to the Harmony Hub? If so, this may help…
In the Harmony smartapp in ST I have selected the Harmony activities so they display in ST as devices.
In the AT smartapp in ST I have then selected the activities so they display in AT as scenes.
Now as long as an activity is selected, whether from the remote or the alexa, AT updates with the current activity.
After this activity is on I just tap the current activated activity and it turns everything attached to that activity off.
I also then added these activities to my ST “Good Night” routine that when run it turns off whatever activity is on, along with a myriad of other automation’s.

I have no virtswitches created to achieve this functionality.

If you do not have a Harmony hub… I will not be of any assistance as I do not use core/webcore.

If this is not what you are looking for I apologize in advance for wasting your time.

1 Like

In the harmony app have the activity turn on the switch for that activity in ST.

I have looked at this again, as I always use AT or Alexa to initiate automation’s. It appears that If turned on via the remote itself it no longer updates my AT as you are experiencing.

having the harmony activity turn on the switch will fix that :point_up: