Harmony Home Control

@thegilbertchan no change for me, made sure both my Hubs were updated and accessible to my Logitech account. When I pull up the "Logitech Harmony (Connect) smart app it doesn’t show my newer hub even after letting it sit at the discovery page for a while.

Even after syncing/updating the Harmony app, I still cant add Smartthings devices to the Harmony app!

No joy here either. I power cycled, re-logged in through Harmony app, etc. – still only my two old(er) hubs and not the third I recently added. I have a workaround for my use case, so I’m good – but happy to try again when an actual fix is implemented.

Didn’t discover my 2 new hubs either…

I have the same issue. Got the new ST hub for Christmas. I added it to the harmony side just fine, but when I go to discover it as a ST “thing” it times out. It says the harmony hub timed out and says to restart it, which I’ve tried several times with no luck.

Alright here is where I am now. I deleted the smart app and added it back, made sure every Hub was upgraded to latest firmware. Harmony connect found all hubs and activities, now I’m back to the issue people were having before, failed to load, credentials! I’ve removed and added the app 5 times and same issue!!!

Thanks for everybody’s replies.

We’re actively working with Logitech to trace down the recent issues with linking up the two services.

1 Like

@thegilbertchan I don’t know if it is related, but I can’t get my Flic app to connect to Harmony. When you login to Harmony, you get put in a loop where it doesn’t think you are logged in. Is this similar to these issues? Not sure if it’ll help.

@brianlees i’m guessing that the mobile browser is caching your login. I’m not sure how to reset this.

Is there a eta for this, I have no hubs added now, just keep getting error:credentials?

Hi all,

The “Logitech Harmony (Connect)” is an officially-published app (installable via “Marketplace -> Entertainment -> Remotes & Buttons -> Logitech -> Logitech Harmony Home Hub”). I have used it and it works for me. I’d like to customize the UI behavior a bit though. Do you know if it is possible to hack this SmartApp and the device types for my own tweaking and customizations? I tried to pull down the version from GitHub and run it. After enabling oauth I was able to launch the SmartApp but the initial login page from “Click to enter Harmony Credentials” gives me errors:

{"error":"invalid_request","error_description":"Missing or invalid argument."}

If you have successfully done this before I’d like to get some pointers. Thanks!

I have the Harmony hub connectivity working, however, whenever I turn off an activity, it instantly reverts back to “on” in the mobile app. Has anyone else experienced this and have any inkling as to how to fix the behavior?

i still have problems with it refreshing properly. I deleted and reinstalled the harmony st app, and it authourizes and finds all hubs and scenes but won’t save properly, meanwhile from within harmony it will authorize but never refresh the things properly. If i change anything i have to unauthorize smartthings in harmony and then re-add it to get all the items to properly populate.

Just picked one of these up today on amazon to integrate into my smarthome setup, and i’d like to use it for an easy way for my wife to turn the alarm on or off. I’ll probably get a multi-button switch eventually, but for now, i’d like her to hit a button on the remote to change between disarmed, armed away, and armed home. is that possible?

Which button remote model did you get?

The harmony home companion button remote has four separate buttons used just to toggle home automation devices that don’t require you to change the current harmony activity. Those can easily be tied to a virtual switch which in turn does the arm/disarm.

If you got one of the other Harmony remote models, you would have to change to an activity to trigger the virtual switch. It’s certainly possible, but it’s a little more clunky.

I got this one: https://www.amazon.com/gp/product/B00N3RFC4G/ref=od_aui_detailpages00?ie=UTF8&psc=1

it looks like the picture you shared. so just use the plug and light buttons for example to trigger a virtual button that is tied to a routine? sounds good, i’ll have to play around with it when it gets here.

Yes, that would be the simplest way if you want to use the Harmony for this use case. :sunglasses: Although if you use rule machine already, you wouldn’t need to use a routine. It can arm/disarm based on switch activity.

is that a smart app? I’m just really getting started with automation, despite having this for over a year now…

Yes, very popular and sophisticated rules engine smartapp. But a routine will work fine, too.

Wow, thank you so much for mentioning that. I was looking for a way to do something like that with smartthings, but it was always specific smartapps or routines had to be run. I’m going to be playing with this for hours…

2 Likes