Harmony Home Control

Maybe the version of Harmony Connect in GitHub isn’t the currently active one, but it contains code to create childDevices for both hubs and individual activities within each hub.

    def addDevice() {
log.trace "Adding Hubs" 
selectedhubs.each { dni ->
def d = getChildDevice(dni)
if(!d) {
def newAction = state.HarmonyHubs.find { it.key == dni }
d = addChildDevice("smartthings", "Logitech Harmony Hub C2C", dni, null, [label:"${newAction.value}"])
log.trace "created ${d.displayName} with id $dni"
poll()
} else {
log.trace "found ${d.displayName} with id $dni already exists"
}
}  
log.trace "Adding Activities" 
selectedactivities.each { dni ->
def d = getChildDevice(dni)
if(!d) {
def newAction = state.HarmonyActivities.find { it.key == dni }
d = addChildDevice("smartthings", "Harmony Activity", dni, null, [label:"${newAction.value} [Harmony Activity]"])
log.trace "created ${d.displayName} with id $dni"
poll()
} else {
log.trace "found ${d.displayName} with id $dni already exists"
}
}    

}

I have 2 “Logitech Harmony Hub C2C” devices (one each for my hubs) and 7 “Harmony Activity” devices for all my activities. To be clear, NONE of these show up in the list available to poll in Pollster. There, I only have a select portion of my light switches.

Do they show up as devices that can be refreshed?
Just making sure they show up at all for pollster.
For me, they are not poll-able, but can be refreshed (although I don’t use pollster, just installed it for testing for this, but I had it available as a SmartApp already)

No, they do not show up in Pollster in the selectable devices. I should have been more clear.

Have you run Harmony Connect recently? I don’t have any devices showing up for me with a fresh install?

Well, so previously (when this wasn’t working), if I clicked on the smart app, it was blank (it said 2 hubs found and 7 activities found but it didn’t list them). After messing around with this a lot today (including trying to uninstall the smart app and start over, which it wouldn’t let me do), now when I click the smart app, the hubs and activities are listed, and – best of all – the activities are reporting properly.

It’s likely this is only temporary (it’s done this before), but we’ll see. Unfortunately, I’m not sure what I might have done to make it work again, as I was messing with stuff in ST and in Harmony.

1 Like

So I think I figured out what was causing ST to “forget” the Harmony activities. If you log in through the Harmony app, for whatever reason, it clears the smart app withing ST. If you then go back and repopulate it, the devices should stick until the next time you mess with things within the Harmony app.

Now, the problem I am having is getting the smart app to recognize a new, third hub. I bought another one yesterday and have it all set up – but the smart app will not show that it’s available. Ugh.

I went through the three steps highlighted above:

  1. Ensure that the firmware is updated on ALL Harmony hubs
  2. Ensure that ALL Harmony hubs are online
  3. Power cycle each Harmony hub

Yet I still only see two hubs when I start the Logitech Harmony (Connect) smart app. Not the third one I recently added to my home. I’ve got the ST integration working within the Harmony app. Please note that I do NOT get an error message; it just only shows “2 hubs found”.

Is there any way to force the smartapp to do a full re-scan? I tried removing the smartapp but it then I do get an error message. Everything works fine with the 2 hubs, just not the third.

Any help you could provide would be appreciated.

I’ve got the same problem. Recently added a second Harmony hub and the app doesn’t seem to be able to see it with the normal refresh. New activities show up just fine, just no new hubs. I’m afraid I’ll end up having to delete the smartapp and start over, but really hoping I can avoid it.

Here’s what I got back from ST support:

“There have been some known issues recently with users being able to discover Harmony hubs with SmartThings. If you have reset the Harmony Hub it and are not able to see it in SmartThings, then unfortunately you might be experiencing this bug. Our developers are working on finding the root cause and getting it fixed, but I regret to say that we are not aware of a work-around for it at the moment. I have tagged your account to get notified when we have an update in place that addresses this. Until then, I’m sorry for the inconvenience this causes.”

Glad I’m not the only one pulling their hair out over this!

I’m also glad that you actually get responses from the support team, I’ve been waiting for support on a number of tickets with no response!

Anyone getting a solution to this? I just added another hub and Smartthings doesn’t discover it

Well, it did take longer than usual. I think they’ll respond to your tickets – but they seem severely backlogged. You would think that the Samsung acquisition would have given them a boost in working capital so they could hire appropriate amounts of technical resources, but perhaps Samsung is taking a hands off approach.

@Derrek113116: No update as it appears they have no clue why this is happening. I don’t know if this is related in any way, but I’m getting lots of “An unexpected error occurred” in ST, regardless of what section I am in or what I am doing. Stuff seems to work (except this hub discovery issue) but the errors are a bit disconcerting.

Yep i have 2 hubs that i added weeks ago they work fine. Got 2 more because love the integration, can’t add them for the life of me. sent support ticket, they told me to power cycle the hub while in discovery. Still nothing, can’t add the 2 new hubs at all.

Hi All,

We’re currently investigating with Harmony the issues you guys have been seeing with adding additional hubs. We were able to reproduce this and trying to track down the issue. Given the holidays it may take us some time to get a fix out.

We will let you know if there’s any workarounds in the meantime.

3 Likes

add me to the list kahn-st@lgk.com see the following post
Another bug since last update harmony
I had tons of crap in the logs so had to delete the harmony authorization and the smart app
when I added the app back It can not see the harmony hub.
in addition harmony can turn on certain switches but turning off is not working

I’m also having issues with adding ST devices from within the harmony app. I have sent an email to ST support. My initial response: “While using the Harmony app on Android, after logging into my smartthings account to add devices it isn’t able to retrieve my devices. I can authorize my devices but after this step it takes me back into the Harmony app and tries to retrieve them but hangs and ask to try again (which produces the same result).”.

This is now the second time the Harmony integration broke. What is the process that is failing? Is it insufficient QA testing on the ST side? Or is Logitech not giving you guys a heads up when they do firmware updates?

This seems broken here in the UK at least.

Authorising from Harmony -> ST or ST -> Harmony fails in both directions.

Please try this again. We got a note from Logitech that recent tests of adding the device is working (which failed previously).

@Mbhforum We haven’t made any changes in the past few weeks to the connect app or device type that could be causing these issues.

@krelltunez and @TheMattS give it another go.