Govee DreamColor LED Strip Lights with WiFi and Smartthings?

You have to download index.html from smartthings-govee-led-lights/index.html at main · uncdubdiver/smartthings-govee-led-lights · GitHub and open it with your browser, i.e. Google Chrome
Like is written on the github page:

This index.html file will provide you step-by-step procedures on add the device and device type handlers into your SmartThings account

I had same issue where once I download index.html file it would open same github page.
Open that index.html in a editor (Notepad++), delete everything and paste “raw” code from github into it and try to open again in Chrome. Good luck!

Any luck with your lights? I had those working but when I added another set H6141 they stopped. I tried removing both, getting new API and setting up new in ST still nothing. H6141 still works. Very odd

Same here. Can’t turn off H6199.

I have a H6199 and I don’t have any problems.
Try re-add it

Removed everything and re-added everything. Still cannot control it. On SmartThings web interface I can see logs of me trying to turning it off/on, but nothing is actually happening. Any other suggestions?

Just want to say thank you to @jc73uk, the author of the DH and all of those that chimed in here.
It is working great. Just wish I could select some scenes from the Govee app in the smartthings.
Thank you again!

2 Likes

Hey guys,

There definitely seems to be an issue with model H6141. I followed the steps twice to make sure I didn’t miss anything. The device shows up in the app in a turned ON state, however I cannot control it. Am I missing something here? TIA


Try to delete the device and re-add it on smartthings and make sure you are using the last DH.

1 Like

Removed and re-added a few times. No luck. Using device handler in the instructions. Where can I find the latest DH?

Here GitHub - uncdubdiver/smartthings-govee-led-lights: Samsung SmartThings integration for Govee LED Light Strips but I just realize that the DH don’t have any updates since Feb 1
Try to open an issue on uncdubdiver/smartthings-govee-led-lights github page

Hi, I had the same problem as you with my Govee H6110 strip. What I did to resolve the problem was to “publish” the new device handler created. Once this done, I could control my Govee strip without any problem.

Hope this help!

1 Like

I want to buy you and the freakin’ awesome developer a huge beer! God damn. I’m so not-tech-savy and I couldnt figure out why it wasnt working. Figured out ( :smiley: ) how to see replies, found yours - instantly worked. God damn! Thank you Benoit!

Hey Benoit
That WORKED!
Thanks a lot sir! much appreciated.

This step needs to be added to the index.html file.

I spoke to Govee recently and they are considering ST integration but not soon. They are “evaluating customer demand” so for official support start emailing them and asking

I will point them to this forum and many other similar ones. Seems they have less work to do :joy:

Good work

1 Like

Great news! I reccomend to share the github Page too

2 Likes

Email sent to Govee. They said they will look into it and note my expression of interest

Email sent.

1 Like