Google Home suddenly looses contact with SmartThings

I have a Samsung Soundbar connected to SmartThings and in turn it is linked to Google Home. The soundbar appears as a switch in Google, so it is only possible to turn it on and off. I have been having this setup for more than a month now.

Few days ago Google suddenly did not recognize a command to turn the soundbar on. I went into the Google Home app and the soundbar had suddenly disappeared. It is still controllable remotely using SmartThings.

In the Google Home “Add device” feature, SmartThings was no longer listed as a linked service. So I searched for and clicked on the SmartThings icon to link it, a message says it’s linking, and then nothing happens. SmartThings still does not appear in the list no matter how many times I do it.

So what I have tried further:

  • Uninstalled the soundbar from SmartThings
  • Removed SmartThings permissions from the Google Security Linked Accounts page
  • Removed link to Google in SmartThings app.
  • Relinked everything again.

SmartThings still does not show up in the list when I try to add devices. I look in the SmartThings app and I see Google is linked. I look in the Google Securty settings and it shows that SmartThings is a linked account. But it doesn’t show up in Google Home.

Anyone had similar issues?

Hey there @SWE,

Thank you for reaching out for assistance and for providing me with the troubleshooting steps that you have already completed.

I’m sorry to hear that you are having issues getting your Sound Bar to be controlled by Google home through your linked Smartthigns Application.

My recommendations would be to first get everything linked again by re-authenticating your credentials to both linked services(Google and Smartthings application) and to clear the cache of the Google Home and smart things applications then restart your mobile device. If you are having issues still with linked accounts (+)Add Device > Linked Services. You can clear the cache by navigating to Settings>Applications>Smartthings App/Google Home>Storage>Clear cache for both and restart.

Most importantly “Ok Googe, Sync Devices”, after getting the devices to show linked I would perform a simple synchronization of the devices to ensure that Google home is synced across all devices and services. I like to do this after I add a new device into my ecosystem or make minor changes that I want to ensure my Google Home recognizes.

I hope this message finds you well!


Hi, thank you for you assistance. I tried your suggestion on clearing cache with no success. I even tried clearing all application data for both Home and SmartThings and unlink the services in both ends in the SmartThings app and on

When re-authenticating, I can succesfully log in to SmartThings with my credentials to the step where I can choose my home from a dropdown list. After that, I get forwarded back to the “add device menu” and when exiting to main screen, still no link. SmartThings appear on /accountlinking?pli=1 and Google appears in SmartThings linked services tab - but in Google Home there is still no Soundbar (even after I tried re-linking the soundbar in SmartThings). So when I once again go into Google Home linked services setting, I only see Assistant and Tuya on the list on linked services and SmartThings does not show up. I even tried to unlink Tuya just to see if that worked, but it didn’t. I think there’s a ghost corrupt SmartThings link somewhere in the Google Home system that is separated from what I see in /accountlinking?pli=1. Since SmartThings does not show up in the “linked services” in the Google Home app, I have not been able to unlink it. Maybe if there’s a way of forcing it to clear the links, then it will re-link from a fresh start?

Thank you for verifying that you have now cleared the cache and as you mentioned the Data and re-authenticated the application and it has taken you back to the “add device menu”.

The next step would be to have Google Synchronize your services. Most importantly “Ok Googe, Sync Devices”.

You can perform that action using the above command in your Google Assistant and You will hear a Voice notification of either the services you mentioned SmartThings, Tuya, etc or it will just provide the number of services that have been linked through the Google Home Application if you have more than a certain number of services linked as I do myself.

After you have heard the notification, the next troubleshooting step to see if the issue was resolved. It would be to close and re-open the Google Home Application.

The next step is to Tap the Icon on the top right corner of the application. Select Assistant Settings>Assisant>Home Control.

Do you see your Smartthings Account here linked with the Sound Bar? Is there a Banner at the top of Home Control Menu letting you know that any devices aren’t assigned to rooms yet? You may find your Sound Bar here. If you do, assign it and check the Google Home application to see if you can now control your Sound Bar.

  • The list should include the services linked and their corresponding devices. For example, mine displays my Smartthings Account and devices, etc. It is a good way of checking if the service that you have just linked to Google has been linked and waiting for a room or what room they are assigned to currently.

I hope this works for you and let me know if it solves your concerns.

Fond Regards,


Hi again,

I forgot to mention that I have tried the sync devices command several times along the process and also after a complete re-authentication. Google Home only replies “OK, syncing Tuya” so there seems to be no communication with SmartThings. Naturally there is also no SmartThings link in the Home Control menu. It is to be emphasized that the link seems to be active both in SmartThings and on the Google account website, but nowhere to be seen in the Google Home app. (Except that I can do the actual authentication when trying to re-link in the app, but the it throws me back to the menu and nothing has seemingly happened.)

Thank you for confirming that information.

At this time, since the Soundbar is functioning and showing up in your Smartthings Application.

I would recommend reaching out directly to the Google Home Application Developers support team for further assistance with their application.

I hope this message finds you well!


Hi there,

Thanks. I Googled a little bit and found this thread:

Seems like many many more users are having the same problem. As they say, the problem is that Google has no access to the SmartThings system although “everything seems linked”. SmartThings developer should be made aware of this and make an effort into checking the login portal. How should we move forward?

Thank you for your feedback and ideas with Samsung.

We appreciate your feedback and will tag it on the forum so that it will appear with other feedback, ideas, and requests.

This will allow your post to be more easily found in the event that Samsung product groups are seeking outside feedback/requests/ideas regarding our products.

I hope this message finds you well!


Hi, just to let you all know that I got an email some days ago about SmartThings rolling out updates. I tried to reconnect SmartThings in my Google Home app and my soundbar magically appeared again. It appears as a strange symbol and I can’t seem to do anything with it … but at least it shows up now. To be continued …