Google Home ONLY works for one user on SmartThings devices, "Encountered an unknown error"


(Jeff Lagana) #1

I found a support case on Google that explains what I’m seeing.

https://support.google.com/googlehome/forum/AAAAXWcshA0EFk5ACOl8C0/?hl=en

I have a ST account with my wife linked. When she connects her ST account to her google home app mine starts throwing the “an unexpected error occurred…” error. If I connect mine her linked ST app breaks and throws the same error. Last one to connect wins.

Has anybody else seen this or fixed it? Right now only one person can use any of the smartthings via Google home/assistant.


#2

I have the same issue and unfortunately haven’t found a solution yet. I’ve contacted ST support a few times and haven’t really gotten anywhere. My next step was to reach out to Google, but haven’t found the time yet.

Wonder why that post said don’t call support?


(Jeff Lagana) #3

I think it was a scammer, the post with the number was removed. Please update of you find a solution.


(Efrain) #4

Same here…any solution for this? Been working fine and sundenly this issue…can’t use 2 Google accounts with ST.


#5

No progress here. . . but also never reached out to Google support, just been too lazy. Posted on the user forum but didn’t get a single response.


(Jeff Lagana) #6

It’s been working for me for a few weeks now.


#7

I haven’t tried in a while. Will try again.


#8

Did you use separate ST logins on separate Google accounts or did you use one ST login on separate Google accounts? I just tried with one ST account on multiple Google accounts and no luck. I didn’t re-link or anything though.


(Jeff Lagana) #9

I have the ST login on my account and she does not. It just started working for her (I guess it uses my account).


#10

Right, forgot you only link a ST account to one Google account. That’s the way I have it and still not working. Maybe I will try and relink and see if that fixes it.

Side note I looked back at the referenced Google help topic and someone suggested creating a custom Google home routine and entering the commands via text (as opposed to using UI). May try that since not many ST commands needed.


(Jeff Lagana) #11

Aaaand it’s broken again…this is getting very frustrating. It’s obviously something on the smartthings or Google side. Hopefully the figure out the issues soon!


#12

My daughter happened to try to enter the commands via text today and that didn’t work either. Bah! Frustrating!


#13

I encountered this problem starting this Wednesday morning Sep. 5th.

I have had SmartThings devices connected to Google Assistant. My wife, using her own Googel Assistant profile, has been able to control SmartThings device. She got the “Go to SmartThigns app to connect devices” error starting on Wednesday. It stil lworks for me.

I tried to unlink and re-link account. Same error.
My wife successfully linked to SmartThings with her own SmartThings account. Got “Can’t connect to SmartThings” when she issue voice commands.
My wife successfully linked to SmartThings with my SmartThings account. Got the same “Can’t connect to SmartThings” when she issue voice commands.

Please help with this, SmartThings Support. I assume you guys rolled out something Tuesday night.


(James Edens) #14

I am having the same problem. Does your wife has an S9? Samsung did some update to the S9 recently and it screed ALL SORTS of stuff up on her phone, including completely dumping her Google home/smartthings integration, forcing me to re-link and setup her account. Now she gets the can’t reach smartthings error on Google home.


#15

My wife and kids can no longer give direct commands to the GH either. /Sigh


#16

The good news is I just checked the GH user forum and it is littered with similar complaints about all sorts of smart systems, not just ST, so hopefully they will look at it.


#17

My wife has an iPhone, @James_Edens . Am pretty sure it is not a phone issue for her. From what I see in the Google Home help forum, this is likely a Google issue.

Thank you for mentioning Google Help forum, @farlicimo. I am looking at some of suggested workaround over there. Hopefully that makes a difference.


#18

i was able to get my wife to work with a workaround. in the Google home app, I unlinked her voice match, so it treats her voice as mine.

gotta love having something like this break when I’m going out of town for 6 days…


#19

Looks like people reporting things starting to work on this thread. Not specific to ST, but a similar and active topic. Not home so haven’t tried my self.

https://support.google.com/googlehome/forum/AAAAXWcshA04BcFALbcofE/?hl=en


(Jeff Lagana) #20

Looks like it’s starting to work again here as well.