SmartThings Community

Google Home Assistance - problems with ST - KNOWN issue to Google

(Chris H) #464

Thanks for keeping an eye on this, Lars.

Everything is working well for me these days, but I will have a big moving-things-around-the-house swticheroo to deal with sometime in the next month, so it’s reassuring to know I have a contact here if I need a hand getting these particular accounts tied back up!

(Troy Kelly) #465

@Lars unable to PM you - unable to link GH with ST - same error from beginning of thread.
New setup, old hardware - was on old platform.


@Lars I can’t PM you, I am too new to the community. My issue is that I am unable to get GH and ST to properly link. Any help would be greatly appreciated.

(Daniel Paquette) #467

hello i currently can’t integrate google home since removing it from smartthings. Had to remove smartthings cuz google home could no longer do searches (tell time, calculate, give internet searches). Now it can do searches but it can no longer control smartthings devices

(Neal ( / #468

Did you attempt to add Google Home back to SmartThings through the Google Home app? I actually had to remove my link with GH yesterday, went back into the Home app, then under Home Control, tap the three dots for the secondary menu, then go to Manage Accounts and find smartthings and just login.

It took a few hours for all devices to start working properly through Google Home however for some reason.

(Daniel Paquette) #469

thanks for the info - unfortunately when i try to link my account it says it currently cant update


I’ve received both of these errors. On one phone, it shows it syncs but Smartthings doesn’t show up in linked accounts. On a different phone, I receive some error about being unable to update.

(David Tee) #471

@Lars unable to PM you - I am having the same issue w/ Google Home and the new samsung smartthings app. My devices are no longer showing up.

(Larry Tuff) #472

Thought I would try to take advantage of the recent Google Home direct support for Harmony (I have two Harmony hubs that I was controlling with Google Home via SmartThings). I removed my main Harmony Hub from SmartThings (leaving the secondary one connected), connected it directly to Google Home and then tried to unlink SmartThings from Google Home (planning on linking it again later so I can still use Google Home to control my second Harmony hub as well as all my other devices). I was able to unlink via my spouse’s phone (she’s the other account on Google Home) and then remove the Google Assistant SmartApp under SmarthThings, but there are still a subset of SmartThings devices (actually they’re all just the Harmony SmartThings commands, all the other SmartThings devices eventually disappeared) showing up in the new Google Home App. When I try to unlink the SmartThings device that is still present there I get a ‘couldn’t update the setting’ message. I have both the SmartThings Classic (I have some device handlers for things like Ecobee and Nest) as well as the new SmartThings connect app and as indicated there are two users on the account. Ideas for unlinking successfully?

(Phil Pettis) #473

I am having the “Can’t unlink Smartthings from google home” issue. PLEASE HELP! Lars? Can you help a brother out? I PM’d you bt have not heard back and still doesn’t work.


I ran into this issue as well. I set my default web browser to “Google chrome” and then it worked fine. :slight_smile:

(Earl Hassett) #475

@Lars I am having the problem with not being able to unlink my Smartthings account with google assistant. I tired everything people recommended factory reset all GHs and reset ST hub. Uninstalled Google home app lots of times. But everytime I log into home to see if ST is gone or try to unlink it I get the stupid Can’t update the settings. Check your connection. Please PM me as I can not pm you. Thank you I have set my default browser to firefox and then back to google chrome neither worked.


Having the same issue, Google Home is really messed up for me right now.


Did any of you talk to Google support about the unlinking issue? Also, can you confirm if Google smartapp is uninstalled first time you try to unlink?


I didn’t contact them…I assume my only google home support option is: Google Home Help - Google Support › googlehome

Checked my Google Home account, SmartThings seems to be unlinked now, assume you fixed it.

Now I just need to contact Google support, as I get the account owner will need to sync, Smartthings, Nest, and SmartLife… and a error occurred. If I try hooking up my services it thinks it’s duped.

(Tom Grant) #480

Lars I sent an email to you as I am also having the unlinking issue. I cant PM here yet. I did contact google support twice and spent a couple hours on this issue. They escalated it to the next tier, but nothing yet. I said an engineer at SmartThings was able to unlink them for multiple users with simply their email account with google. They said they have no tools to allow this. Please help.


Question to everyone who is experiencing the unlink issue.

Have you linked from multiple Google accounts to your SmartThings account at the same time?

(Austin Spangrud) #482

I think I removed from Google smartapp first then went over to the Google home app.

I only linked one Google home account to my smart things account. My wife to hers. The only work around I’ve found is we had a third account where I can add and remove smart things from my Google home, which makes me think it was a migration issue because it says I’m not the account owner


Did one Google account link to main ST account?
And another Google account linked to the shared ST account?

(Austin Spangrud) #484

Yes that was how it was originally.

I had my main and my wife had hers as separate. So we had two different Google smartapps. I removed both hers and my smartapps, then tried removing from Google home. Her Google home app removed the smart things setup. But mine can’t. I’m stuck with an error of not being able to remove it. If I try to sync the devices it says that the account owner needs to set up smart things. But I’m the account owner.

Edit: looks like you or something happened and it has now been fixed

Edit edit: looks like I still have phantom devices connected to my home account. So there is now double of everything in my Google home app. Then when I try to sync my devices I still get this issue stating that I’m not the Samsung account owner… When I am.

Edit: I’ve removed smart things from my Google home account. But it is still coming up with that issue. There is no link to smart things at all in my Google home. But still says I’m not the account owner.