SmartThings Community

Google Home Assistance - problems with ST - KNOWN issue to Google

(Adrian Marano) #21

I have the same problem, after the update i am not able to see my devices

(Cosmin Borodan) #22

hello! please please can you help with a step by step?
same problem! i am on the eu shard and i think google home is connecting to the us server and it does not find any devices.:frowning:

(Cosmin Borodan) #23

hello
i have the same problem? have you found a solution?

(Adrian Marano) #24

Anybody found a solution?

(Not Dexter) #25

A SmartThings engineer acknowledged the problem on Facebook and ST has updated their Google Home documentation. Apparently Google botched it by removing the ability to add devices. They apparently are supposed to add on their own now, but you have to unlink/relink ST in GH to get that functionality.

I’m not thrilled, as I have many rooms and devices in GH, and tons of custom IFTTT automation (custom phrases tied to specific devices). I’m worried all that will break and I’ll have to add everything all over again. Additionally, I have many devices and routines that I don’t want exposed to GH and voice control. Seems that ability (checking boxes on what ST things you want included in GH) is now gone, as everything comes over. What a complete mess.

I’m gonna wait on the unlink/relink until others report what happens.

#26

I have not found a solution to this. I had spent an hour with Google Home support and also logged a ticket with SmartThings. Will update if there is any progress.

#27

Some of us are experiencing issues with relinking. I.e. Google Home runs into an error during the linking process. I would think it is a good idea to not do the unlinking/relinking at this point.

1 Like
(Adrian Marano) #28

That’s my problem, i unlink my account to add a new device, and now i am not able to link my account again ( popup a conexión error after authorize my location)

(Ahmed ElSerafy) #29

Which update are you talking about and i think you should get back to ST / GH support for this.

#30

So I DID do the unlink/relink. When that happens EVERYTHING comes over and you have to re-associate all the devices to rooms.

Another issue that pops up is that if you have multiple devices with the same word in them, GH gets confused and asks “which XXX device did you want to turn on”. This was the main reason I liked the selective adding. For instance, I had a room called kitchen that contained a “Kitchen Light” (Trendsetter Group), a “Counter” light, and a “Ceiling Fan” light. The “Kitchen Light” actually had individual Osram bulbs that I called “Kitchen1” and “Kitchen2”. I had to rename ALL of my individual lights, since they came over. Before, I had just brought over the trendsetter groups.

Also, you have to take the redundant lights (Kitchen1 - Now Ktchn1, Kitchen2 - Now Ktchn2, and Kitchen Light - Now called "Cooking Light for instance) out of the same rooms. Otherwise, turning them on by saying “turn on kitchen” was creating havoc. My workaround was to create a “Not Used” group/room.

I am afraid to try the “turn on everything” or “turn off everything” now as there are devices that exist individually, and as part of trendsetter (or other) groups. My workaround here was to create a virtual switch tied to a routine, and use that to turn on/off all lights. This turned out cool as I created a phrase “Let there be light” to turn everything on in the house, and “And then there was darkness” to turn them all off before walking out the door. Kids think that is soooo cool. LOL

1 Like
(Cosmin Borodan) #31

The problem i think is somehow relatet with the update front 3 august for
me! And with the location of the of the hub in the eu server! Google home
is trying to link with the us server ( i have no hub there ) and is finding
nothing! Obvious!
I will try to chat with smartthing suport!

(Adrian Marano) #32

i think so, when google ask for my devices, it’s on https://graph.api.smartthings.com/device/list and my devices are on https://graph-na02-useast1.api.smartthings.com/

I dont know how to change this, GH goes automatly to that address

(Wesley Wong) #33

After unlink the account. I having the issue to relink with smartthings account in Google home app. Any suggestions?

(Not Dexter) #34

Yeah, your setup sounds a lot like mine (Hue bulbs grouped with a virtual dimmer). I like the Not Used group as a workaround.

I’ve been having problems with my “Back Light” - a GH change recently now uses “back” as a keyword for turning things “back on”. “Turn on Back Light” is apparently interpreted as “turn lights back on” or something, and it decided that it should now turn all of my lights on. Had to setup an IFTTT Google Assistant phrase for that light to isolate that command to just the back light again.

I don’t think ST/Google tested their integration much at all, because the recent changes are major and affecting how many folks use these services. Fundamental changes like device synchronization should have been at minimum communicated by ST.

(Adrian Marano) #35

I think… after the update GH lost the ability to redirect to the correct shard https://graph-na02-useast1.api.smartthings.com/

But i dont know how to solve it

(Raylon) #36

Exact same problem that I could not authorize Google Assistant to add devices. No solution found as yet. Any luck after ohdan?

(Dean Craig) #37

This seems to be a common problem. My GH quit recognizing any devices. I contacted GH support and they had me reboot, reload, delete and reinstall software and finally the system worked again for One Day. Then crashed again. I thought I had solved the problem by separately connecting Hue, Honeywell, and Leutron hubs. I then had to reload all the rooms and names on GH. I then added 4 GE switches that could only be connect to my ST hub. So, I relinked to the ST hub and selected the 4 new GE switches through ST. Then two day ago they could no longer be recognized. I unlinked ST and relinked. But now I could no longer select individual devices. All my ST devices got loaded and GH now has duplicates for any device on my other hubs that was on ST. Now rather than 41 devices, I have 77 devices listed on GH. Then last night GH quit recognizing any device. Today I unlinked ST and the 41 original devices work through GH but I can’t add the 4 GE devices without adding the other 41 as duplicates. And when I do, GH will crash again.

.

(David Manson) #38

I attempted the unlink ST from GH and now it’s stuck. I’ve had a case open with Google for three days with no resolution. I show several Hue devices and the unlink repeatedly says successful, but it remains in my list and since it’s still technically linked I cannot re-link. Really painful, basically completely out of commission on Google issued voice commands. Alexa still works…

(Vik Heg) #39

Same problem here. Works fine with Amazon Echo. Google Home is completely out of commission.

(Adrian Marano) #40

Same problem, all was working great until i unlink my ST from GH. Now when i try to relink, i can’t, GH gave me this error “could not update setting please check your connection”