SmartThings Community

Google Home Assistance - problems with ST - KNOWN issue to Google

Never mind I Googled it.:grin:

so far how is your problem? can link to google home? mine still unable to link.

I had the same problem. I unlinked ST and In was able to operate Nest again. I’m just going to leave it unlinked until ST get fixed.

Un-linking ST allows GH to work with other services. What baffles me is the small number of people complaining.

Samsung and Google make money from selling their $100 devices - if they can’t team up and sell a lot of them, that seems silly. To me, they seem a match made in heaven, or at least they used to.

1 Like

I can link, but it puts 160 devices and then no voice recognition works beyond music, weather and google searches.

Hi everyone, we have now updated the Google integration to allow you to select devices if you so choose. By default, all supported devices are still exposed. However, if you open the smartapp it will allow you to turn that off and select individual devices (as well as enabling/disabling access to routines). Any changes you make will sync to Google Assistant within a few seconds.

10 Likes

Thank you!!!

Unlinked/relinked ST/Google and everything worked as you described. Thank you @Lars!!

Thanks for taking care of us!

THANK YOU! We GH users are very grateful for your support and assistance with this issue - thank you again for your prompt help with getting this resolved!!

Awesome. I am up and working again. Thank you Lars and smartthings.

This works GREAT!!

THANK YOU GUYS SO MUCH!!

What about Google Assistant? Whatever I do, I cannot authorize Google Assistant when trying to add devices.

Screenshot_2017-08-15-22-06-22[216]

Glad to see that this was addressed.

However the verbage in the Google Smart app might need some revising.

So are door locks not supported or are they partially supported? It’s a bit confusing

There may be an easier way to do it, but I went with the burn-it-down-&-start-from-scratch approach…

I don’t actually integrate much from my ST setup into GH, so this wasn’t too painful for me.

In the GH app, I unlinked my ST account altogether. I think that action removed the “Google Asistant” smartapp from within my ST app, but maybe I then manually removed that too - I don’t recall for sure.

I then re-linked my ST account in the GH app, just as if it was a new setup.

Once that was done, the Google Asistant smart app automatically reappeared within the Smartapps section my ST app - in this new form, it’s now named just plain “Google”.

Within the ST app, tap on that new “Google” smartapp - that will open the various setup management options…

Start by DEselecting (i.e. turning off) the first option - “Allow Google Assistant to access all devices and routines”…

When you do that, then you get the option to select which specific Switches and Thermostats within ST that you want added into GH. Routines are still an all-or-nothing deal.

Save changes - be sure to tap on Done in the upper right corner.

Then go back in the GH app, and confirm that your desired selections show up there… Finally, assign nicknames and rooms as desired.

1 Like

Hi @Lars. The link issue for eu shard still exists. I’m not able to link my smartthings account after authorize. In iPhone show the blank page and in Android shown “could not update setting. Please check connection”.

This not only fixed the issue, but made it better. I wonder if this was their plan all along, and Google just jumped the gun on GH before the ST app was ready. Thank you!

1 Like

Thanks @Lars.

I am facing the issue of the “blank page” on the iPhone as well. Is the team working on that?

I just logged into my Google Home app and am now seeing all devices again. I can see in my SmartThings app that I have only authorized the devices I want to use, but they are all showing up in my Google Home.

I managed to get my devices linked to google home (UK SmartThings set). Could be that an official fix was issued or I just got lucky but I’m not about to unlink and relink to find out.

Here’s what I did.

  • Do the usual “add device” on GH app. After clicking on “authorize”, wait for the usual “something went wrong, try again” screen.
  • Go to ST app. Go to Smartapps and click on the Google Smartapp.
  • Uncheck “Allow GH to control all devices”. Make sure no devices are selected. Next, select just one device. I suggest to use the least complicated one, i.e. a simple switch (without multiple end points). Click done to save.
  • Go back to the GH app, do the usual “add device” steps. I got a different error message this time. The message is a pop-up that says “Unable to add device from graph.api.smartthings.com. Please try again”.
  • Go back to ST app and go to the Google Smartapp. Now, I saw that the checkbox for “Allow Google to control all devices” is active again. Uncheck and again, select only for one switch to be exposed to Google Home. Click done to save.
  • Force close the GH app. Reopen it. Do the “add device” steps again. At this point, it worked for me and GH found one device.

After that, I just went back to the ST app and select all the devices I want to be controlled by GH. Force close and reopen the GH app to refresh.

Let me know if this helps.