Go Control garage door opener


I only get the correct status of my garage door if i tap the refresh button on the classic smartthings app. Once i tap refresh the correct status is reported. Opening and closing the garage door work just fine. It seems like the status should refresh automatically on the app. Any help is appreciated.


Has it ever worked? (Yes It’s supposed to)
Have you recently put fresh batteries in your gocontrol’s tilt sensor?

It is working in the sense that once i tap the refresh button on the smartthings app the correct status of the garage door is reported. If i dont tap the refresh button the status is never reported: if the garage door is open , it will say closed until i tap refresh. I will try new battery.

By working, I meant without requiring a refresh. Its definitely supposed to be able to work without refreshing. (all of mine have in the past and thd two I currently have work without refreshing)

  1. verify you have fresh batteries in the sensor. Then cycle the door to get it to update.

  2. if that doesn’t work you may have a ZWave connectivity issue, try a ZWave repair and / or add a repeater.

Thanks again for helping.

I put in fresh baterry. I cycle the door. Same behavior.
I have zwave devices all over the house and including in the garage so i would think conectivity is not an issue. The gocontrol unit itself never drops off and responds normally to open and close commands. It’s just that i have to tap refresh to get the correct status. Maybe the unit is bad?

No it has never worked as far as reporting the correct status.

As a follow up: After I tried everything I gave up. I ended up getting a new unit. The new unit works exactly how it is supposed to. Thanks for taking te time for helping.