Gledopto Zigbee RGB controller not working with V3 hub


After reading on here that this controller works with Smartthings I bought one from eBay and gave it a go with my V3 hub but it could not be found when searching for new Things. The controller gets picked up by my Amazon Echo Plus, which I believe uses the same Zigbee protocol as the Smartthings hub (HA1.2), so I can’t understand how it isn’t even found as an unknown device in Smartthings…

Please see this thread (later posts showing mine and anothers attempts to get this working). Gledopto Zigbee RGB controller

Anybody have an idea of why it might not work with V3 Hubs?



are you using the new app or classic?

I use the Classic app, but also tried the new app. No joy with either.

hmm, it should at least find it as a “Thing” using the Classic app. How far from the hub are you trying to pair it?

I tried it right next to the hub multiple times. Even took the hub and the controller away from my router to the other side of the house incase of interference. Still nothing!

i’m assuming you’ve tried resetting the device? Stick with the Classic app. The new one requires a couple extra steps to get it into general inclusion mode.

1 Like

Yeah, I switched the device power on and off 5x which makes the LED strip flash white and then searched for the device. Tried that many many times! It wasn’t the easiest to pair with my Echo Plus to be honest but I managed to do it twice so am quite sure I have done the procedure correctly. Another user is also having the same issue…

1 Like

I’m also using a V3 hub and can’t get this controller to be discovered. Did you ever figure it out?

I’m not having any luck resetting the controller either, so I’m not sure where my issue lies.

I have the V3 Hub and I am using the new SmartThings app on Android. This is what I did to solve this.

I set everything up in the new app, locations, rooms, etc.
I downloaded the Classic smartthings app from Google Play
Logged into it and I could see all my settings from the new SmartThings app.
Opened the classic app and searched for a new device. The Gledopto controller was found as a “Thing”.
Closed the classic app.
Went to
Looked in My devices and saw that it was there.
Clicked on the device and it brought up the details.

  • Clicked on “EDIT” at the bottom of the page (in Red)
  • I changed the name from “Thing” to “LED Strip”
  • Assigned it to my “kitchen”
  • Changed type from the default to “ZLL RGBW Bulb”.
    Saved it
    Opened up my SmartThings app (new) and there it was. I could control it!

Hope this helps someone in the future!

Now, I would love to get the thing to have some animations, etc. Seems pretty vanilla to me. More work to do unless someone has any idea on how to do this?


1 Like