Ghost ZHA switch haunting me!


#1

Hi all, wondering if someone could shed a little light on what’s going on here. Still green behind the gills in terms of creating device handlers, i.e. I hope I can work out what’s going on here and how to fix it.

So merry as I am, the other day I bought a handful of these cheapskate Hongbong zigbee switches:

They appear identical also on the inside, yet only 2 out of 3 works (pairs but doesn’t react to commands). But hey, what do you expect for about 8 bucks a pop, right? :slight_smile: And just to be clear, I know the hardware is working (will get back to that)

The ones that work, come up as this in the IDE:
model: “Lamp_”
application: 01
manufacturer: “SZ”
endpointId: “0B”
Raw Description 0B 0104 0100 00 05 0000 0003 0004 0005 0006 01 0000
All well and good it plops into a ZigBee Switch device type and works from the getgo.

Now the culprit swich that doesn’t work, does indeed pair after a factory reset (unplug+replug 5 times), yet it registers with the name “Thing” as an Unknown type". In the ST app, the new device comes up as a "Tile missingThe details look like this:

model: “Power Outlet 220”
application:
manufacturer: “HoneyGeek”
endpointId: “0A”
Raw Description 0A 0104 0009 00 05 0000 0003 0004 0015 0006 00

Now if I understand the cluster information correctly the device reports it’s a basic on/off switch, supporting groups, scenes and identify commands?

Going into the IDE, I edit the device and change the type to “ZigBee Switch” and Update it. Once saved, the device information changes:

model: “DimLight-01”
application:
manufacturer: “HG”
endpointId: “08”
Raw Description 08 0104 0100 00 05 0000 0003 0004 0005 0006 01 0000

Note the clusters change, and are now identical to the working switch’s. However, no cigar. The device still doesn’t react to any commands. On a whim I tried a few other device types to see if I could get anything working. Actually I did (somewhat):

Changing the device type to a “Zigbee Test Harness”, I get a load of test buttons to press in the ST app. I found out if I send an Identify command I can make the switch trigger it’s relay on-off-on-off in a perpetual loop until I stop it with the “Identify stop” command.

In conclusion the hardware seems to work, yet this particular ZHA switch seems to speaking a different language than the other switches. Perhaps I’m reaching here, yet I was hoping that it would be a matter modifying a Switch device handler, finding out the proper command to send by inspectin this test harness business.

Can anyone offer some good suggestions how to solve this?
Thanks a bunch
/Max


(Jimmy) #2

What device type did the working two get assigned? Assign the non-working one that type. Those may be ZLL.


#3

Hi Jimmy, thanks for your reply - the working switches registerd as the “ZigBee Switch” type. And yep, that was the first I tried; setting the borked switch to the same type, however it unfortunately made no difference. Only way I can make the third switch do anything is by assigning it the “Zigbee Test Harness” type as described above.