Devices Mysteriously Discsonnecting


(Steve) #1

Heya Everyone,

I have I fairly large (although not as large as a lot of you guys) setup which includes Phillip Hue lights, Shladge Door Locks, Iris key pads, Iris open/close sensors, GE Zwave light switches, a garage door opener, two Amazon Alexas, and some other items. It has worked pretty well for years, and things that havent’ worked, I have been able to get help here to solve the problem. I’m hoping you ladies and gents can come to my rescue again!

So I recently upgraded (or downgraded, but that’s a discussion for another day) to a Norton Core router in July. Since then, I have had some mysterious things happen (although one started in June before I got the router, so it may be completely unrelated).

I’ve had a few devices disappear from my smart home setup (1 Iris Sensor, 1 GE Zwave Lightswitch, and one Philips Hue Lightstrip (although it can be controlled with the Philips Hue app)).

I’ve also lost voice control from Alexa on any SmartThings devices. Alexa tells me she has a problem and to uninstall and reinstall the Samsung Smarthings Skill. So naturally, I did this. It did not work.

I deleted the profile for the switch and sensor in the web IDE, and neither of them are re-pairing. I’m about ready to just blow everything out, factory reset the hub (if thats even possible) and rebuild the entire network, but I’m hoping that someone here has experienced this and can point me in the right direction.

Thanks again for being the best community out there! =)

-Steve


(Steve) #2

I did forget to mention, I ran wireshark to sniff my network traffic and I am seeing a ton of ARP requests from the ST Hub for a specific IP… I’m wondering if it is trying to possibly get an IP for the light switch and can’t for some reason.


(Jimmy) #3

The only devices you have that communicate over LAN is the Phillips Hue hub, so WireShark won’t do much good. It’s possible your new router is using a different wifi channel that is interfering with your SmartThings and/or Hue zigbee channels.


(Steve) #4

Doesn’t the SmartThings Hub receive IPs from the DHCP server and issue them to the devices? Otherwise why would the hub be making ARP requests every few seconds for the same IP?


(Steve) #5

It might be that the ST Hubs acts as a DHCP for the devices themselves, but that still doesn’t explain the arp requests. Either way, its not that important. I thought about the wifi channels too, but unfortunately with the Core you can’t change the channels… A lot of the advanced router features that I am used to aren’t available =/


(Jimmy) #6

z-wave and zigbee devices don’t use IP addresses. Can you at least check the channel used to see if it may be interfering? you can view the SmartThings zigbee channel in the IDE.


(Jason "The Enabler" as deemed so by @Smart) #7

Hello,
My advice is to learn as much as you can about the way your home automation works, that helps a whole lot in troubleshooting when you have issues.

Your ST hub is hardwired to your router and so is the Phillips Bridge.

  • Phillips Bridge has a radio in that talks to each of its device over a zigbee protocol channel.
  • SmartThings hub has 2 radio’s that talk to its device over a zigbee protocol channel and a zwave protocol channel.
  • SmartThings hub and Phillips Bridge talk to each other via your LAN. Unless you have an actual wi-fi enabled smart device, NONE of your devices care about your LAN.
  • Zigbee Protocol runs on a 2.4 ghz frequency, just like your wifi. The thing is, the wifi is usually a much stronger signal and if the the router and the ST hub are on the same channel, or close, then the router is likely going to interfere with the zigbee in the ST hub.

So, the first thing you should look at is, as mentioned above, check the routers 2.4ghz channel and check your ST hub zigbee channel. If they are the same, change one. There are a ton of links online that will tell you what channels to stay away from and how you might want to set it up.
Second, make sure your ST hub is not sitting right next to your router. They should be at least 3 feet away, but if you can get them further, do it.

Let us know how things look once you check those, then we can help you some more.


(Steve) #8

My hub is now completely offline, even after a hard reset. I’ll check as soon as it comes back up. I didn’t realize that Zigbee and Z-Wave did not incorporate TCP/IP.


(Steve) #9

So, my hub has been offline for over 24 hours now, with a blue LED lit. My router shows that it is connected and has an IP address… I’m wondering if the whole issue was a problem with the hub to begin with.


(jkp) #10

Blue (solid)

What it means: Attempting connection to the SmartThings cloud/servers

What to do: A solid blue light is expected during the normal setup process and when downloading firmware updates (in some cases). However, if the light remains solid blue for longer than 5 minutes, this indicates the Hub is unable to establish a connection with our servers. This problem can occur when outbound traffic from a local network is being blocked. Double-check your network settings and make sure the following ports are open during initial setup: 11111, 9443, 443, 39500, and 37


(Steve) #11

SOLVED
Solved the problem today. I replaced the CAT 5 cable between the hub and router and it came back online. Solved the device disappearing issue by turning off device health. Now everything is magically back as it should be and working fine =)

Thank you to everyone who contributed and helped solve this very frustrating issue =)