Ghost Device

2021-09-30T18:38:14.753497003+00:00 WARN Switch  device_init: <ZigbeeDevice: fc0198f9-6a26-43d8-b73e-fb1a7d2382bc [0x11A8] (Bedroom)>
2021-09-30T18:38:14.760713003+00:00 INFO Xiaomi Switch  <ZigbeeDevice: fc0198f9-6a26-43d8-b73e-fb1a7d2382bc [0x11A8] (Bedroom)> emitting event: {"attribute_id":"numberOfButtons","component_id":"main","capability_id":"button","state":{"value":2}}
2021-09-30T18:38:14.781169003+00:00 INFO Xiaomi Switch  Found config for device: lumi.ctrl_neutral2
2021-09-30T18:38:14.875503003+00:00 DEBUG Xiaomi Switch  Bedroom device thread event handled

but there is no device with the name “Bedroom” or “networkId”: “11A8” in the device list.

it was removed a day ago and now it is not possible to re-add it to the device list

Let me see if I understand you correctly. You installed the device named “Bedroom” but then deleted it.
However, you keep receiving events from it in the logs and you cannot pair it again, correct?

Try to restart the Zigbee device to the default config, this should trigger an unpair event and in the logs, you should receive the “removed” lifecycle.

could you please tell me in detail what to do? The “Bedroom” Zigbee device does not exists in the app list anymore, only in the driver.

Sure, what I mean is restarting the physical device to its manufacturer configuration. The process depends on each manufacturer, but generally, you need to press a button for several seconds.

yes, I keep getting the device_init and info_changed events from it.

I have already restarted the device and even paired-unpaired it with another hub. So device is ok.
The issue is in ST driver so apparently, it was not unpaired fully and stayed in some internal device list. I already even restarted the hub, no luck

2021-09-30T19:26:11.038416708+00:00 INFO Xiaomi Switch <ZigbeeDevice: fc0198f9-6a26-43d8-b73e-fb1a7d2382bc [0x11A8] (Bedroom)> received lifecycle event: infoChanged

Yes, I agree that it wasn’t unpaired correctly, that’s why we need to trigger the unpair event from the physical device so the corresponding Hub receives it.
Restarting the Hub won’t work, this process could help us, you might need to do it more than once until you receive the “removed” event.
If after this, you still cannot delete the device, please provide this info by DM:

  • Device ID
  • Driver ID

but I can not pair the device anymore, so the ST Hub would not receive unpair event.

If after this, you still cannot delete the device, please provide this info:

Thank you for the information. Also, can you describe your steps previous to the issue so we can know what might have triggered it? Eg.

Scenario A:

  1. You made changes to the device profile of your driver (the device was already installed)
  2. Then you noticed the device wasn’t working correctly and deleted it from the app

Scenario B:

  1. You created the driver using the default configuration
  2. Installed the device and for some reason, you deleted it from the app
  • yesterday I have paired next to the last device (Bedroom) and started to move my rules from SmartLights app to automations in the iOS app.
  • there were several “network” errors but then I just ignored themre and clicked “retry” couple of times
  • went for a short walk approximately at same time
  • when I came back I found out that all of my automations and scenes went missing :frowning: and when I tried to create an automations I kept getting the same “network error”
  • next morning I tried to use my Android phone and had the same issue with automations.
    And also one or two “Untitled” devices with no detail page. One of them was apparently the fc0198f9-6a26-43d8-b73e-fb1a7d2382bc .
  • I removed these devices and tried to re-pair that device with no luck. Reset/reboot of everything did not help.
  • I reset the device and get it connected it to another hub.

so it’s probably a server problem and my actions combined. My best guess is that I was making changes when one of the servers went down and some of the settings were lost .

Did you receive these network errors only when you tried to create an automation with the driver?

Before creating the automation, did all the capabilities work correctly?

So it’s possible those devices were only driver-based?

most likely, I do not remember. As it said “Network” I did not pay much attention.

Before creating the automation, did all the capabilities work correctly?

well, there were no errors in the log.
But I am not a LUA programmer, half of my driver is copy-paste from samples another half is the co-pilot auto-completions.

So it’s possible those devices were only driver-based?

Yes, most likely

The steps that @nayelyz is suggesting are the correct ones, I have suffered it 2 times.
The first one, it was solved with this proccess:

The second time was more complex:

  • open logcat with affected driver
  • with the device in pairing mode, search nearby.
  • The device Will paired with the driver to which it was hooked and you will see activity from this device in the logcat.
  • reset the device.
  • check in logcat if you get the lifecycle removed.
  • Repeat this until you receive the lifecycle removed when resetting the device.
  • If this does not happen, you will not be able to remove the driver from the hub.
    it took me several hours to get it, with the help of @nayelyz

It can be maddening

@nayelyz Can you remove the device on your side?

It seems like there is no public API for that

Sure, I already created a report about this, the engineering team will be able to analyze the issue if your device is still in the same status. I’ll let you know about the progress.