GE Zwave Switch Unable to join

About a week ago I have 9 GE zwave switched go offline. I have tried everything I can find to get them back online and they will not rejoin. I also had a few on order that showed up and I am unable to get those to join. Any ideas or tricks to get them back would be great.
Things attempted

  1. Air Gap (Pulled breaker and Air Gap Plug)
  2. Factory reset(3 Up and 3 Down)
  3. Exclusion - saw the device leave
  4. New switch install

Thanks

If you have any custom device handlers installed then you will need to login to IDE, open them and select Publish for Me. Exclude the devices again and try to pair them. There is a known issue where custom device handlers can become stale preventing the devices that use those DTHs from pairing.

2 Likes

Did you validate that the device is gone 100% by checking the IDE or looking in the Classic app? If any of those devices were in any SmartApp, then you’ve fallen victim to this:

If I were you I’d check the IDE to make sure the device is gone because the new app thinks it is, but it isn’t.

1 Like

I have gone through and made sure everything is published and then ran a repair. The device is still offline and the brand new device was not seen when trying to add. This was done in the classic app.
I was concerned the zwave module died as most of the switched that were lost were zwave but the GE zwave motion sensors are still registering.
Is that a way to identify a conflict in handlers?

Additional steps

  1. Publish all Device Handlers
  2. disable zwave radio
  3. enable zwave radio
  4. zwave repair.
  5. Add new device - Classic App - Failed

Bummer, OK. I was really hoping you were using the new app…

Have you rebooted the hub (remove batteries if you have a v2)?

When adding the device, are the hub’s LED’s blinking green (slow first, and then quickly when it sees the device)?

Also, these switches should not need a custom DTH, but just in case, which model, and are you adding the switch based on a general add or by brand/model?

1 Like

Have you screened the hub events log to make sure you don’t see a bunch of ghosts popping up? If you have ghosts, they may prevent the switch you are trying to include, to reach the hub. However, if you were able to see the exclusion successful, you should be able to include it too. As @johnconstantelo said, GE switches don’t require custom DTH. Try deleting the DTH, then include. You can use custom DTH later if you need to.

I tried a hard reset of the hub but is was still a no go.
The hub status light will go to a flashing green and the logs show the status a searching.
The logs only show one other item but it is streaming a lot. I am not sure what it is.

Device Offline
[Garage Lights] Z-Wave Dimmer Switch Generic(unable to find this DTH to remove)
New Switch

Logs
020-01-27 5:12:46.330 PM EST
moments ago HUB zwStatus ready Z-Wave include search ende
2020-01-27 5:12:39.940 PM EST
moments ago HUB ssdpTerm urn:schemas-upnp-org:device:M… devicetype:04, mac:000E58FDB03A, networkAddress:C0A8007C, deviceAddress:0578, stringCount:04, ssdpPath:/xml/device_description…
…
[2020-01-27 5:11:33.223 PM EST
moments ago HUB zwStatus include search Z-Wave include search started

Thank you for the assist.

This sounds EXACTLY like what I ran into. Heres how I got mine to add.

Here’s what I ended up doing that seemed to work more often than not:

Run the search for device in classic. Let it time out. Instead of retrying the search hit cancel. THEN immediately run a search for devices again. Poof - there’s the device that didn’t add…

If it didn’t add, I kept that cycle until I found them all (I had 6 act like this recently)

1 Like

That is a native DTH, you don’t need to remove it. Are you sure you’ve successfully excluded it? What about Z-Wave repair, do you see any errors in Hub Events log (ide). I’ve added 4 of these past weekend, two of them were hard to include for some reason. The search would time out faster. Maybe coincidence or not, but, I had to have the lights on then hit the paddle up 3 to 5 times consecutively. I used Classic app to exclude, then immediately to include.

I gave it a try to include the devices(1 new 1old) with the method of multiple click and it failed. I have even tried moving to a iphone to try to add and it was a failure as well.
I am thinking I may have to start fresh with a full wipe of the hub and clear out all DTH.

Well I nuked my location and was still unable to add a zwave device. Sonos was found no problem and a zibee bulb worked fine. I figured it was the hub so I ordered a V3 hub and I was able to add a new switch with no problem. I then reset a switch and added it back. Went to the third switch and it added with no problem. All is looking good until I tried the devices and found that I was unable to control them from the phone. When I activated the switch the device was registering the change in switch position. Ran a repair and it was unable to find the path to the devices. I have now removed them all and will try again. I am thinking I have a rogue device but I am not sure. I will try disabling all the devices and see what happens but this will have to wait until monday when the wife is gone as she has had it with me(SMARTHOME) today.
Any further ideas would be great.

you need to exclude the device first, the device still thinks it is included with your network. to do so, do a general exclusion, in z-wave utilities, and press the device button, ST will tell you device was excluded. now you can include device.

1 Like

Final Update for those that find this later when working on a similar issue.
The V3 Hub arrived and I created a new samsung account for the hub. At first devices would not join the new hub and after an hour of trying I put it down for a few days. 4 days later I tried again and everything joined the hub without issue. not sure what was keeping devices from joining a few days earlier but all is good now.
Thanks for all those that provided info and assistance.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.