Bug Deleting Devices (in new app only)?

Tagging @Brad_ST and @blake.arnold

I’ll submit a support ticket if needed, but I wanted to run this across here in case it’s something I’m doing, or if it’s really something to send to support.

When deleting a device through the new app, I get confirmation that the device has been deleted, and it’s no longer in the Room I had it in; BUT I can still see it in the IDE and in the Classic app (including controlling it).

If I delete the device in the Classic app, of course it does delete it and it does go away.

Here’s what I’ve found that I think is causing the new app to not delete the device properly. It turns out that the device I tried to delete was set up in the Alexa SmartApp (I forgot about that and yes, I should have checked the IDE, I know, but still…). Since the new app doesn’t have a way to show you which SmartApps, Automations, or Scenes it’s in when deleting the device, perhaps something on the “backend” isn’t working as expected? The device was removed from an Automation and a Scene it was in, but just not a SmartApp.

I’ve seen this happen twice now, but I don’t have another device I plan on deleting for a week or two to see if it happens again; and I really don’t want to delete a device just to replicate the problem and have to deal with adding it back again.

Let me know if you guys want a ticket, or if it’s a known issue being fixed in an upcoming release. I’m also curious if any other member of the community has run across this issue.

@johnconstantelo, What device have you tried to remove? Is it listed in the new app at the bottom, but not in the room by any chance? Or under the devices?

Nope, it was a zwave device I’ve had for a very long time (few years at least). It always showed up and worked properly in both apps.

After deleting it in the new app, I looked everywhere for it - the original Room it was in, under unassigned, and in all devices. It wasn’t listed at all. In the Classic app it was still under Devices and well as the original Room that it was in all those years. I was hoping to find it so I could try deleting it again after I removed it from the Alexa SmartApp, but my only options were to delete it from the IDE or the Classic app (preferred method, which I used).

I just asked because I have just seen similar with the LIFX bulbs. But I had to realise, the LIFX Connect SmartApp has to be deleted in the Classic App.
Different story, as it is C2C. And the new integration is working.