GE ZigBee smart switching stops working once paired


I just installed my first ZigBee in-wall smart switch from GE (model 45856GE, this one), and I’m having an issue I can only describe as odd:

  • I installed it in a simple single-switch setup, no traveler
  • Wiring should be correct, and I believe that’s also confirmed by many things described below
  • When turning on the breaker, the blue LED starts blinking, as expected
  • While unpaired, I can turn on/off the light without issues using the physical control
  • Once paired, things get odd
  • I can turn the light on/off via the smartthings app
  • When I push the physical button, the light doesn’t get turned on/off
  • However the blue LED does the expected thing: It turns on when I (supposedly) turn off the light and turns back off when I (supposedly) turn on the light, but as said above, the light never actually changes state.

I already tried unpairing the switch (via the 10 clicks) and repairing, but no change.

I’m sure you agree this sounds more like a software issue than an problem with my install, but it still irritates me to no end :slight_smile:

Any ideas or suggestions what might be going on here?


I literally just installed one of these too, and it’s doing the exact same thing. That’s really odd because I tested functionality before putting the wall plate back on.

Let me dig into this a little more and I’ll reply back.

Yup, something funky is going on. I just emailed Jasco support. It could be a firmware issue on their end perhaps.

The IDE logs show absolutely nothing when using the device physically.

Thanks for confirming and I’m glad it’s not just me :slight_smile:
Im guessing you haven’t heard back yet from them?

Not yet…

I moved the switch to a different location and was able to repeat the problem. At first I thought it could just be an issue with the physical buttons, but when it worked prior to being paired, my theory was debunked.

I’ll give a little longer to reply, and then I’ll call.

I just got an email"


Thank you for contacting Jasco Products Company. Unfortunately, we have not heard of this issue before. This is new to us. What app are you using? Is it the new SmartThings Connect app or is it the SmartThings Classic app? We will get with our product management to see if this issue can be replicated. We apologize for the inconvenience. We will keep you updated if a solution is found.

I’ve sent them the link to this discussion, and answered their question. Hopefully they can replicate this like we can.

Thanks for sending it! If you haven’t mentioned it already, feel free to point out that you’re not alone :slight_smile: I actually emailed them as well a day after you did, but haven’t heard back yet.

1 Like

Oh I did.

Just now I excluded the switch from ST and it started working again manually, and as soon as I rejoined it, it stopped. I was turning it on and off during the rejoin process, and as soon as ST saw it, it stopped working manually. So weird.

I was also watching the IDE live log, and there’s noting in live log being sent from the switch when being manually used. I think they have a firmware issue, but it will be hard to diagnose. Hopefully they’ll replace our switches.

@johnconstantelo, @lnhrr we have identified the problem and are working on a fix . If you’d like you can self publish the DTHs from that PR, then power cycle switch, wait about 10 seconds and then click Refresh in the Classic app. At that point it should be fully functional again and you can switch back to whatever DTH you were using before.

1 Like

Hey @tpmanley! How cool is that, thanks for catching this discussion. I’ll try that right now and let you know here.

Thanks @tpmanley, that worked perfectly. Thank you!

Glad to hear it @johnconstantelo!

I was thinking about this a little more and was just about to post back that I think just the power cycle and the refresh should be enough to fix the issue. Self publishing the DTH would only be required for it to be fixed automatically on join. Sorry about that.

No worries at all. I have the day off to get stuff done around the house, and this was an easy chore.

1 Like

Hey Tom - awesome, thanks for your help! I’ll try that out when I get home. Just to be clear, as I didn’t follow everything being said here: Did I understand you correctly that since you changed SmartThings’ default handler for this, I don’t need to publish my own to fix it? In fact I don’t even need to remove and rejoin the switch, just turn off the breaker feeding it for 10s and upon restart it should pick up the changes? Sorry if I misunderstood your instructions.

And separate question: The description on your linked pull request seems to indicate this is actually not a problem with the switch, but rather with the firmware of the hub itself, is that correct? Does that mean the root cause could actually also affect other devices in the future?

Thanks for your help!

Yes, however, you will also need to press the “refresh” button for the device in the classic app.

Potentially yes. We are also fixing it there, but the turnaround on firmware changes is a little longer. However, this is a fairly unique issue, so I would say that’s pretty unlikely.

1 Like

Ok, that makes sense, thanks for the quick reaction & responses!

I’ll try this tonight at home and will update.

1 Like

Yep this fixed it, thank you very much for your help!

1 Like