GE Z-Wave Switch LED on Switch not working


(Joel W) #1

I have a GE Z-Wave switch and I have the built in LED set to be on when switch is off, but it doesn’t lite. Anyone know how to get it to go on? I have tried the 3 taps on on and 1 tap on off, but no luck.


(Realy Living Dream) #2

Did you try changing it in the device on ST ?


(Joel W) #3

Yes and tried the other DH in setup. It is set to be on when switch is off. Other than the LED it works fine.


(Realy Living Dream) #4

Did it ever work ? You can try doing a ZW repair and replace of the device. I have 1 that the LED just seems to have a mind of its own. I have never been able to figure out why. Regardless of how I set it, it is always on.


(Joel W) #5

Doing a Z-Wave repair now. I wouldn’t mind if it was on all the time.


(Joel W) #6

No luck Z-Wave repair went Ok but didn’t fix.


(Realy Living Dream) #7

Did you do a repair and replace of the device ? Not ZW network repair . Open the device, click the hamburger , hit replace .


(Michael) #8

I recently removed a switch and readded it and noticed the same thing. I ended up going into the device preferences and set it to come on when on, even though it was already set that way and clicked done. Then waited a few minutes and changed to on when off and that fixed it for me.


(Joel W) #9

I did replace an it said device not considered failed. So that didn’t work. I also tried setting it to on when on and waited no luck.


#10

Did you ever figure this out?

I have many GE dimmers and and switches and I’ve been waiting for the infamous failures (my oldest device is about a year old). None have failed yet but I have just one switch where the blue indicator LED has now failed. The switch otherwise works just fine.